Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I rarely use on my Mac (I prefer the GMail browser client and I keep closed most of the time) but I'd like to have a full backup of my GMail account on my laptop. So far I have 34269 messages but that's only through May 13.

On the menu, when I click Mailbox > Get All New Mail or pressing the toolbar Get Mail button both yield unsatisfactory results: only 2 to 10 messages are downloaded. I'm not getting any error messages but it's just not getting everything up to date all at once like I'd expect. It's rather sporadic.

At one point the last month, I would open and it would fetch like 900-1000 messages but now I have to repeatedly click the Get Mail button, which is taking an eternity (I'm signed up to mailing lists with high numbers of messages.)

I checked the troubleshooting on Google's help pages:

From that last one, Quote:

In order to resolve this issue, please try the following troubleshooting steps:

  1. If you're not using recent mode, ensure that the option to Remove copy from server after retrieving a message in the Advanced tab of your POP client settings is checked.
  2. Try enabling recent mode in your POP client by replacing '' in the Username field of your POP client settings with '', and uncheck the box next to Remove copy from server after retrieving a message in your Advanced POP client settings. Recent mode fetches the last 30 days of mail, regardless of any other factors. If you don't Leave messages on server your messages will be moved to Trash after download.
  3. Try deleting the entry for your Gmail address in your POP client and then re-adding it with all the correct settings. Please note that you may lose your local copy of any previously downloaded Gmail messages.
  4. Try Gmail IMAP as a better alternative to accessing your messages on your mail client.

End quote.

I'm not using "recent mode" because I don't want to remove the messages on the server, I just want a full copy locally; old and new mail are equally valuable to me for my purposes.

The same thing happens whether I have "Remove copy from server after retrieving a message" checked or not (nothing is removed on the GMail side of things and messages are not being downloaded in bulk). And I'd like to avoid re-downloading all 34000+ messages.


Weird, I set to check for new mail every minute and now it freely chose to download 927 messages, and now it's getting 881 more. That brings me up to June 16. Perhaps this is resolved? I suppose even if it only did small batches I could just leave open all day... Oh, here come 1044 more messages. Right now I have "Remove copy from server after retrieving a message" unchecked... Oh, and 986 more; that's more like it. Up to date through July 2, 2009. Not sure what changed... I think the answer is to uncheck that "Remove ..." and to set to check for new mail every minute and just let work its magic.

share|improve this question
up vote 4 down vote accepted

the problem was not with, it was a gmail configuration problem.

in "Settings > Forwarding and POP/IMAP" there is the option "POP Download":

  • Enable POP for all mail
  • Enable POP for mail that arrives from now on

I guess you checked the second one while you wanted the first one.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .