Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a multiboot system, each system on a separate hard drive. I've been using GRUB2 and everything was fine. I've recently decided to switch to BURG and that keeps my Windows 8 in a reboot loop. I've disabled Automatic Restart, so I could actually see the message, but it says nothing important - "Your PC needs to restart", "error code 0x00000050" and four (memory?) addresses.

I couldn't find anything related to this error and I've spent hours on various forums and support sites. I've kept the original MBR on the Windows hard drive/partition so I can boot from it.

So, to clear things up, I don't want an alternative solution to running Win8 with Ubuntu (I can always switch back to GRUB or use my hard drive with Win8/MBR as a boot device), I want to find what causes this behavior and I'd like to fix it.

I've even copied the original GRUB menu entry for Windows 8 (from os-prober, the one that worked/works) to the new BURG config, updated it, checked if it appears in burg.cfg and all that, but still, the results were the same. I tried adding a new chainloader entry, specifying the partition - same results as well.

Could it be because BURG uses some GUI modifications? Could that be bothering the Win loader?

My menu entries:

menuentry "Windows 8 (loader) (on /dev/sda1)" --class windows --class os {  
    insmod part_msdos
    insmod ntfs
    set root='hd0,msdos1'
    if [ x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1  01CA6F821330B030
    else
      search --no-floppy --fs-uuid --set=root 01CA6F821330B030
    fi
    drivemap -s (hd0) ${root}
    chainloader +1
}

menuentry "Win8 Chainloader"{
    set root='(hd0,1)'
    search --no-floppy --fs-uuid --set 01CA6F821330B030
    drivemap -s (hd0) ${root}
    chainloader +1
}

p.s. this question is related and interesting

share|improve this question

using "chainloader /EFI/Microsoft/Boot/bootmgfw.efi" instead of "chainloader +1" work partly , still have a error message but it boot

in my case Ubuntu doesn't do anything specific for uefi system

i did change the chainloader option in /etc/grub.d/30_os-prober ( the dirty way)

or you add the modified menu entry to /etc/grub.d/40_custom (the proper way)

but this is just a work around , i would guess that installing the grub-efi package could solve the problem (didn't test it)

take a look at https://help.ubuntu.com/community/UEFIBooting for more detailed infos

i hope it help you

share|improve this answer
    
The thing is that my Win8 Chainloader entry is actually copied from a working GRUB entry yet it's not working when launched from BURG. No idea why, that's what I'm trying to figure out. I'll try the change you suggested, I believe I had it in GRUB at some point (also working)... And I'm not using UEFI. Thank you for answering. – Shomz May 2 '13 at 14:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .