Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My BIOS used to let me press a key (F8) which I could press during the POST to have it present a list (figure 1) of all detected storage devices so that I can choose which one to boot from (also, when the key was pressed, it would show a message like F8 pressed, showing boot menu... until the POST finished).

I have used that feature a few times since I got this motherboard (P4P800) a couple of years ago, but it seems to be missing now. Pressing Del to access the BIOS config program still works (and still shows the Entering setup... message until the POST is finished), but the other keys no longer seem to work.

I don’t know when this behavior started because I use the boot-selection menu infrequently, but the only significant changes to the system since the last time it worked was to add some RAM to the system so that I can use dual-channel mode (and change the AGP Aperture to 4MB to maximize available RAM on a 32-bit system), and to add my old card-reader (it just plugs into a USB port on the backplane).

I have tried changing the settings to default (through the BIOS function) but that did not fix it. I also checked the BIOS for any and all related settings without success: I tried changing the boot device and priority settings through every permutation I could, enabled/disabled the quick-boot setting and the fullscreen logo. Not surprisingly, none of these affected it since they were not changed since it last worked…

The last step I can think of is to re-flash the BIOS (it’s already the last version) and clear the setting via the motherboard jumpers. I doubt that would work because there is no reason that it should have changed (short of some virus or gamma ray or something that somehow managed to get through the router and software and alter the BIOS of an old motherboard for some reason).

I could find pretty much no pages where this issue is mentioned. The closest I could find was the opposite, where some people complaining that the menu is popping up and asking how to stop that.

One page referenced the keyboard as a possible cause which reminded me that my previous keyboard was wireless so, the F-Lock function was always on, but my new one is wired, and the F-Lock key always resets to off when I turn the system on, making the function-keys behave differently. Of course I have already tried turning it before pressing F8 repeatedly, so that is not the problem. I also tried connecting a USB keyboard and a PS/2 keyboard and had the same results.

Has anybody seen this (BIOS keys/boot-menu go missing)? Does anybody have any ideas?

Figure 1: Boot-device selection menu

Screenshot of boot-select menu

share|improve this question
    
I’ll note that last night, the system started having trouble staying off. Shutting down (in any way) would turn it off but then a couple of seconds later it would turn back on. Again, this is new behavior without recent related changes, but the new symptom seems like it could be linked to the BIOS. (Like I said, I can’t fathom why the BIOS would become corrupted…) –  Synetech Apr 29 '13 at 17:57
    
It sounds silly even to me that I'm writing it, but have you checked inside the BIOS if there is an option to enable/diable it? Also it may be worthing to search for BIOS manufacturer documentation to see if it tells something. –  Sekhemty Apr 29 '13 at 18:04
    
Like I said, I also checked the BIOS for any and all related settings without success. –  Synetech Apr 29 '13 at 18:13
    
search for BIOS manufacturer documentation to see if it tells something Oddly enough, it’s not even mentioned in the manual. But I know it existed, I didn’t dream it up. I considered that maybe it was part of my previous motherboard, but the manual for that doesn’t mention it either. –  Synetech Apr 29 '13 at 18:15
    
I'm sorry but I don't have any other idea. My comments were a bit obvious but I've never heard of this kind of issue before. Maybe trying another function key instead of F8 if it was silently remapped, but it seems a bit unlikely. –  Sekhemty Apr 29 '13 at 18:24
show 1 more comment

2 Answers

up vote 1 down vote accepted

Solution

The problem is only peripherally related to booting. It turns out that the issue is with the settings under Boot⇨Security Settings.

What happens is that if you change the User Access Level setting from Full Access to anything else (i.e., lower), then the BIOS does not show the prompt or accept the boot-selection key.

This seems bizarre, but has a slightly logical purpose. The rationale is likely that if you lower user access, then you also want to prevent users from booting from a different device (i.e., in schools, businesses, etc.)

Analysis

The problem is that AMI (and possibly other BIOS manufacturers) has done a poor job in their labeling and design:

  • The layout, labels, logic, etc. all lead a user to believe that the user-access settings specifically control the BIOS configuration program; there is no indication that it affects other matters outside the BIOS editor like the boot-menu. This assumption is strengthened by the fact that there is a setting that determines whether the BIOS asks for a password on setup or always.

  • There are no user-access settings that allow for using the boot menu but prevent changing BIOS settings.

  • This behavior is exhibited even if the ask-for-password setting is set to Setup, meaning that users do not have to enter a password to boot.

  • This behavior is exhibited even if no user password is installed at all.

The fact that the boot-selection menu is not even mentioned in the manual (even the latest one) makes it sound like the whole thing is just a last-minute addition, an afterthought which could explain why it is was implemented poorly. Of course the manual is for this specific motherboard, and AMI (and others) provide BIOSes to multiple manufacturers for multiple models, so unless AMI added the boot-menu just before ASUS used it in this line of boards, then it is just an example of bad logic/interface design which leads to confusion.

Summary

Either way, I figured out how to get the boot-menu back (which is much easier than having to alter the boot order in the BIOS whenever I need to boot from something else), and hopefully anybody else who runs into this will find their way here for the solution.

share|improve this answer
add comment

I agree with your "last step" idea of reflashing and clearing settings via motherboard jumpers. You may want to clear the settings first just to see if, for some odd reason, it makes a difference. That sort of behavior in BIOS does sound really wonky though.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.