Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Since yesterday, I cannot run vmplayer.

The last time I run it, about one week ago, it was working well. I've made several updates since this time, but no update to vmware itself.

I've rebuild the kernel too, but I've run module-rebuild build.

I'm on Gentoo.

Whenever I try to launch it, it outputs this error:

NOT_IMPLEMENTED /build/mts/release/bora-1031769/bora/lib/misc/codeset.c:1708 [1] 3542 abort /opt/vmware/bin/vmplayer

I tried unmerging vmware and reinstalling it again, but it didn't worked.

If I rename the folder containing the virtual machine, vmplayer launchs correctly, but then, when I try to open the virtual machine, it crashes with the same error.

Does that mean that my virtual machine is bugged ?

Does someone know a solution to this problem ?

Here are the versions installed:

  • app-emulation/vmware-modules-271.2
  • app-emulation/vmware-player-5.0.2.1031769
  • app-emulation/vmware-tools-8.8.5.893925
share|improve this question

1 Answer 1

up vote 2 down vote accepted

I'm on gentoo as well and have the same problem. I'm using vmware-workstation-9.0.2.1031769 and get

~ $ vmware
I/O warning : failed to load external entity "/etc/vmware/hostd/proxy.xml"
NOT_IMPLEMENTED /build/mts/release/bora-1031769/bora/lib/misc/codeset.c:1708

Only thing I can remember is an update of the package "dev-libs/icu" from version 49.1.2 to 51.1 which made me uninstall libreoffice as of incompatiblilty. The rest of the normal updates went well without surprises. (I usually do an "emerge -auDNv @world" two or three times a week.)

I'm going to undo the icu update and see if that resolves the issue. Will report back...

Edit: typo

share|improve this answer
    
It works :) I checked the list of updates, but this one wasn't looking suspect. But now, it looks logical as icu is for unicode and codeset looks encoding too :) –  Baptiste Wicht May 2 '13 at 8:47
    
Glad we found it! Works here as well. –  Uwe May 2 '13 at 8:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.