Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been trying to setup a pair of systems to be Primary and Secondary Servers for the Fail safe systems. I prepared both the systems with Windows Server 2008 32 Bit. For replication, I have took a System Image Backup from the primary and tried to restore the same on the secondary machine.

The System restoration succeeded and after restoring the system was up and some of the PnP drivers went in toss. The secondary machine continuously asking for installation of drivers for 'New Hardware Found' viz., System Interrupt Controllers, SM Bus Controller. But all the driver installation failed on local drive store, Windows Update and manual installation too.

By following this link, I solved the driver problems. But now, the Network Port in the machine is not getting detected and not even listed on the Device Manager. Tried 'Scan for Hardware Changes', but vain. Checked the registry for the installed drivers, the registry have the entry but still the Network port is undetectable.

Please help me to solve this trouble. Thanks a lots in advance :)

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

The below suggestions are for : Wired LAN Network Onboard System with a physical machine / server

I assume both machines are different , hence the driver complication issue. If they were the same, there would not be "new hardware found" issues. Ok, what type of machines are these ?

I would firstly check if when you have the machine powered up, if there's any kind of activity on the network LED's at the back of the machine, when you have the cable plugged (I do hope this is a wired LAN system). There should be a orange and green LED's flickering/on.

Also I advise you to check in the BIOS of the machine and see if the network device has been enabled. A firmware or BIOS update to the server might also be a good idea.

If you do have the time and the soft&hardware, I urge you to install a fresh os on a fresh hard drive on that server and then see if the network controller is picked up. If it is NOT after all these attempts, then your network controller on your mainboard might just be faulty.

Also check in the device manager with options "show hidden device" to see if the device is maybe somewhere there.

Note : I personally use "Driver Packs" for most drivers. The current version is 13 and is about 4.5 GB on DVD . I recommend that for anyone who needs drivers as this has most drivers of most machines...

share|improve this answer
1  
I hate driver packs its much easier to find only the drivers you need. Plus most of those driver packs and programs to help locate drivers are infected with malware. –  Ramhound Apr 30 '13 at 11:30
    
Thanks for demoting my post. I never had any virus / malware issues with driver packs. We run Kaspersky on a cooparate level +200 license on a domain network and personally I have Avast. I have used it on countless machines and never had any complains / issues with clients complaining about malware - even scans revealed no malware or viruses on such machines. Last but not least it's easier for any client to use driver packs, than to find drivers on their own. Not every computer user is so highly skilled and advanced as you, Ramhound... –  cyberion1985 May 2 '13 at 8:49
    
let's see, there is only one version 13... of driver pack(S)...on DVD which is about 4.5 GB, which is the full suite application. I believe it's a full ISO. It's not a "driver pack" it's Driver Packs DVD. That's the one I was referring to. –  cyberion1985 May 2 '13 at 13:21
    
I still would rather get the driver from the horses mouth. –  Ramhound May 2 '13 at 13:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.