Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Specs: gigabyte ep35-ds3 Motherboard Intel Dual Core 2Duo 2.87GHz Processor AMD Radeon HD 6670 Video Card 2 Gb RAM

Couple of days ago my screen suddenly went black when I was working on some AutoCAD software. When I tried to reboot/shutdown/removing power cable, every time after I saw the windows 8 loading logo, screen went black before reaching login screen.

Eventually, after I formatted my PC, deleted all the partitions, erased all the data that was left, I installed Windows 7 with SP1. Then updated it with windows update, installed chipset updated drivers, audio drivers and then drivers for the video card from their website.

I also installed .net Framework 4.0 as a prerequisite for a latest Catalyst 13.4 suite. After reboot I can log into windows, see desktop, open folders, change screen resolution, even ran DXDiag and it was fine. But when I tried to open any program (IE, Media Player and so on) the screen went black again and didn’t respond even to Ctrl-Alt-Delete. It also went black when I tried to open "System" from control panel. One of the programs that didn't make my screen go black was a notepad (comforting). If I don't install a video driver from AMD website and leave the original Standard VGA Graphics Adapter from Windows, everything works fine (except from the ability to use a graphics card properly of course).

Any suggestions what could be wrong and what should I do?

share|improve this question
    
What is the resolution your Graphics hardware supports ? –  Buscar웃 Apr 30 '13 at 10:05
    
Have you tried booting into Safe Mode (F8) and do you then experience the same issue? –  packets Apr 30 '13 at 11:39
    
Are you sure Catalyst 13.4 even still supports your card? –  Ramhound Apr 30 '13 at 11:53
    
I did try safe mode, and the result was the same. Catalyst 13.4 supports my card according to their release notes. And I doubt it has something to do with the resolution since it worked just fine before. I tried something new however, and it got me thinking that maybe a power supply is the problem. When I disconnected one of the fans, and thus lowered power consumption, the screen didn't go black everytime like before –  Slava Apr 30 '13 at 13:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.