Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

To setup Hadoop I am installing CYGWIN on my 32 bit Windows 7 machine. It has installed successfully without any error.

CYGWIN Setup version : 2.774
$ uname -r : 1.7.17(0.262/5/3)

SSHD installed successfully, When I try to start CYGWINSSHD from services.msc either it doesn't start OR it starts and stops instantaneously. when I start it using cygwin termical it says..

$ net start sshd
The CYGWIN sshd service is starting.
The CYGWIN sshd service could not be started.
The service did not report an error.
More help is available by typing NET HELPMSG 3534.

I have googled a lot tried a lot.. but didnt succeeded.

P.S.

  • Also tried with disabled firewall and anti virus.
  • Installed CYGWIN and always start terminal as Administrator.

How can I resolve this and make sshd start, running smoothly when ever I start it?

Any help would be great to me. Thanks!

share|improve this question

migrated from stackoverflow.com Apr 30 '13 at 10:42

This question came from our site for professional and enthusiast programmers.

    
What does /var/log/sshd.log say? –  devnull Apr 30 '13 at 9:19
1  
What does NET HELPMSG 3534 say? –  dave4420 Apr 30 '13 at 10:03
    
have you run ssh-host-config and ssh-user-config? –  dawud Apr 30 '13 at 10:43
    
@devnull it says "Privilege separation user sshd does not exist" @dawud yes run ssh-host-config but not ssh-user-config. –  manurajhada Apr 30 '13 at 11:02
    
Okay, Thanks @devnull because of your guidance I found a link and that solved my problem : codept.blogspot.in/2007/11/… But now when I run ssh localhost it says Connection closed by ::1. What to do now? –  manurajhada Apr 30 '13 at 11:11

1 Answer 1

As suggested by @devNull I read /var/log/sshd.log and file said Privilege separation user sshd does not exist. When googled the issue found a BlogPost that solved my problem smoothly and that instructed to

Add this line into /etc/passwd file,

sshd:x:74:74:Privilege-separated SSH:/var/empty/sshd:/sbin/nologin

and this line into /etc/group file,

/etc/group:sshd:*:27:

P.S. : The purpose of this answer is just to maintain a log/StickyNote to the problem and its solution for self and others.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.