Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to RDP from an x64 Windows 7 to an x86 Windows XP SP3.

The connection is very slow: a screen redraw when switching full-screen windows takes several seconds, up to 20s if there are many images or a single large one taking the whole screen.

I have unchecked all bells and whistles to make the operation as fast as possible.

I have disabled the "Large Send Offload v2" on the network interface of the client.

I have tweaked the receive window auto-tuning on the client:

> netsh interface tcp show global
Querying active state...

TCP Global Parameters
----------------------------------------------
Receive-Side Scaling State          : enabled
Chimney Offload State               : automatic
NetDMA State                        : enabled
Direct Cache Acess (DCA)            : disabled
Receive Window Auto-Tuning Level    : highlyrestricted
Add-On Congestion Control Provider  : none
ECN Capability                      : disabled
RFC 1323 Timestamps                 : disabled

The .rdp file looks like this:

screen mode id:i:1
use multimon:i:0
session bpp:i:16
winposstr:s:0,3,0,0,800,600
compression:i:1
keyboardhook:i:1
audiocapturemode:i:0
videoplaybackmode:i:1
connection type:i:1
networkautodetect:i:0
bandwidthautodetect:i:1
displayconnectionbar:i:1
enableworkspacereconnect:i:0
disable wallpaper:i:1
allow font smoothing:i:0
allow desktop composition:i:0
disable full window drag:i:1
disable menu anims:i:1
disable themes:i:1
disable cursor setting:i:0
bitmapcachepersistenable:i:1
audiomode:i:0
redirectprinters:i:0
redirectcomports:i:0
redirectsmartcards:i:0
redirectclipboard:i:1
redirectposdevices:i:0
drivestoredirect:s:C:\;
autoreconnection enabled:i:1
authentication level:i:0
prompt for credentials:i:0
negotiate security layer:i:1
remoteapplicationmode:i:0
alternate shell:s:
shell working directory:s:
gatewayhostname:s:
gatewayusagemethod:i:4
gatewaycredentialssource:i:4
gatewayprofileusagemethod:i:0
promptcredentialonce:i:0
use redirection server name:i:0
rdgiskdcproxy:i:0
kdcproxyname:s:
desktopwidth:i:1680
desktopheight:i:1050

Nothing seems to help.

What am I missing?

Edit: responses to comments:

The processor on server-side (XP) is an old Athlon 3500+ but it should be up to the task.
The resolution is 1680x1050. Full screen (1920x1200) is even slower.

The bandwidth and latency of both machines, tested on May 1st:

XP Server:
XP Server

Win7 Client:
Win7 Client

share|improve this question
2  
What's the CPU load on the XP box? (I assume you're not seeing any slowness on the Windows 7 side other than in the RDP connection.) If it's not very powerful, and especially if you're also using a very large RDP window (e.g. 1920x1080), you may just be asking more of it than it can handle. –  Aaron Miller Apr 30 '13 at 16:58
    
To paraphrase Aaron, try not using full screen and see if it works better. –  user 99572 is fine Apr 30 '13 at 17:19
    
You gave us the bandwidth of both connections, but not the latency, which may be the problem here –  golimar Apr 30 '13 at 17:33
    
answered comments in the body of the question. Latency should not be the issue since mouse tracking is fast. –  Alex O Apr 30 '13 at 19:00
    
@alex VERIFY what the latency is exactly! –  Ramhound May 1 '13 at 0:59

1 Answer 1

up vote 0 down vote accepted

Nothing out the ordinary I reckon.

You say the XP host's upload speed it 0.98Mbs. This is the limiting factor.

I've just connected to my work PC, at a high resolution (~1700x900).

It took a good long while to load up a full screen of google images.

The upload speed at the host is 0.96.

So I would suggest that you have no problem (other than the problem we both have: terrible upload speeds)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.