Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have linux mint 14 MATE edition installed on a T430 lenovo thinkpad laptop. Yesterday, I wanted to test my bootable USB drive on the machine. After 1 or 2 minutes it booted fine. I created a file to test if it persisted on my USB drive, and then I immediately shut it down. When I removed the USB drive, and rebooted my HD install, the system was effed up:

  • The menu bar (start bar equivalent for windows users) is completely gone
  • ctrl-alt delete no longer points to the task manager
  • double clicking on an executable text files gives me a dialog asking if i should execute it rather than opening in a text editor like i had configured it
  • My desktop's icons are arranged differently than before (looks like default)

It seems like the USB boot completely reverted my linux mint settings, in addition to destroying my menu bar. Does anyone have any idea what might have happened, and how i might fix it? This is kinda shaking my confidence in linux mint and USB booting (which I had assumed would not change anything on my system without my explicit command). I don't even know how to access the settings to attempt to do anything about this.

In fact, I don't even know how to access a terminal via the windowing system - I had alt-t set to this, but it no longer opens a terminal. I can go to a bare terminal, but it'd be nice to be able to open a terminal in the windowing system so I can at least try to start up the mate-menu program.

_ UPDATE _

I found a way to fix my problem - now I just want to figure out how to prevent my USB boot from doing it again. Basically, looks like the problem was that my USB boot wrote to some config file on my hard drive which created a different session context. The mate menu might have been broken because it pointed to files that no longer existed because the USB drive was unplugged. I'll post a fix to the breakage, but I will accept someone's answer if they tell me how to make my USB boot not mess with my harddrive, but instead write to its own storage space (which I did provide when I installed it using Unetbootin- 4gb).

share|improve this question
1  
What file did you create? It seems like your home folder was wiped or modified... –  Darth Android Apr 30 '13 at 20:18
    
Just a normal, empty text file on the desktop. –  B T Apr 30 '13 at 20:36

1 Answer 1

up vote 0 down vote accepted

I restored my system from this problem by shutting down to get to the login screen (I couldn't simply log out since there was no menu), clicking on the Sessions button, and selecting MATE from the menu instead of "Last Session". When you log in, it will ask you if you want to make that default - say yes. Then you're back in business, thankfully.

share|improve this answer
    
Unfortunately, I deleted a bunch of mate settings from my home drive in an attempt to fix the problem. It didn't help, and now I have to rest those settings up. Not a big deal but bleh.. –  B T Apr 30 '13 at 20:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.