Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Alright, this one got me stumped...
Bear with me. This is a long story:

I'm trying to help out a family member with a clean install of Windows 7 (Ultimate, 32 bit) on his ASUS A7Sv laptop.
Laptop came originally with Vista, which got hosed by a virus, including the restore partition.
ASUS doesn't support Win7 on this laptop, but it should work.
Hardware is quite common: Core2Duo on an Intel ICH8M chipset.
Win7 should find all hardware out of the box. (Except for the special Hotkeys, but I can always install the Vista Hotkey utility, which is known to work on Win7.)

Have to install from USB as the buildin DVD player is broken. (I removed the DVD-drive from the machine so it can't interfere with the install.)

I've got an USB-key Win7 installer which I know is good. I have installed about 30 machines with it before this. (And even another system after this just to make sure the USB isn't damaged.)
The USB install has SP1, hotfixes upto December 2012 and all known SATA/SATA-raid & USB3 drivers slipstreamed into it.
I installed another laptop some months ago, (different brand with nearly identical hardware,) with this same USB-stick without any problems.

Setup proceeds as normal until the point where it need to load the mass-storage drivers.
Then it asks for a CD/DVD driver.
I know this is not really the CD/DVD driver: Win7 wants a mass-storage driver.

I have tried every mass-storage driver I can get my hands on: ICH8M, ICH8, ICH8R, old versions, new versions, the Vista version supplied by ASUS. Even the JMicron drivers for the eSATA (which I'm not using). Just to make sure I also tried the Intel Turbo Memory drivers, even though I don't intend to use these.

Nothing convinces Win7 to continue with the install. (Although it accepts these drivers, they are compatible with the hardware.)
Stupid thing is: If I run Shift-F10 and launch DISKPART I can see the HD fine. I can partition and format it without any problems.

Any ideas which driver Win7 is looking for ? Any other suggestions ?
(Don't bother suggesting re-plugging the USB-stick in another port. That only works if you booted from an USB port on Bios emulation so Win7 needs to rediscover the USB with it's own drivers. That is NOT the case here.)

Update: Tried it with the mSata cache flash module removed too. (Thought that might interfere somehow). No joy either.

share|improve this question
1  
How can you install Win 7 Ultimate on his machine? Did he purchase a license? –  Keltari Apr 30 '13 at 20:09
    
2 other things you could try: 1) get an external usb dvd/cd set up and try installing from that instead of usb. 2) pull the HDD out of the laptop and install using another computer (pull all existing sata/ide cables besides the desired install HDD and the dvd/cd drive. After that, plug it back in to the laptop and see if it boots up. You'll likely have to clean up some messes but if it gets it installed, that's the goal right? Also ASUS might have a specific sata/ide driver on their website for the laptop you could try to find/use. –  Enigma Apr 30 '13 at 20:49
    
@Keltari He bought a retail license last year for another computer. That computer now runs Linux. Retail licenses can be moved to another system so this is legit. –  Tonny Apr 30 '13 at 21:16
    
@Enigma I exhausted the ASUS supplied drivers already. They are just the stock Intel Storage drivers and an old version of those too. I will borrow an external USB DVD drive from the office tomorrow (it has eSATA too, can try that as well). The "install via another computer" trick is always an option, but that would be very messy. Is really a last resort, if all else fails thing. –  Tonny Apr 30 '13 at 21:19
    
Looking at specs for the laptop, I am guessing that some "mass-storage class" drivers required may be nvidia-based, not intel based. –  horatio Apr 30 '13 at 21:52

1 Answer 1

Answering myself. Might be of benefit to some people.

This evening I added an external DVD drive on the eSata port.
Booted an original Win7 Ultimate DVD without any problems.
Loaded the jMicron driver for the eSata interface from USB stick and installation continued and completed without a hitch.

I strongly suspect that there is something in the way this Bios initializes USB boot support for USB memory-sticks that messes with the things Win7 expects to see.
When booting from DVD there is no issue at all. Who would have guessed.

Lesson learned: An external DVD drive with eSata interface is a very useful thing to have lying around for such corner cases.

Update 4-5-2014:
Would you believe it ??
Just ran into the SAME problem again, this time with a Acer Aspire M1641 desktop. (Of course Acer and Asus belong to the same mother-company and chances are they get their weird Bios form the same source.)
Because this is desktop the Bios has some more elaborate options that gave me another clue: The USB stick is detected as a 2nd harddisk and treated by the Bios as such. This seems to throw the Windows 7 installer in a fit.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.