Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was using system mechanic which is not working properly it gives an "unknown error". I have tried to uninstall and re-install , tried to remove it completely from registry , tried to re-install it in another user account same issue, i am using windows 7, but i have a friend who used windows xp and getting the same error. How to identify why exactly it shows this error. Any ideas to fix it?

share|improve this question
1  
Is it a paid registered version? – Karan Apr 30 '13 at 22:24
    
don't use such tools which only cause more errors compared to what they fix/improve. – magicandre1981 May 1 '13 at 7:29
    
it is a paid version. – Rohit May 14 '13 at 13:58

For starter you can look at Event Viewer -> Windows Logs -> Application. It should give you more details about error itself.

share|improve this answer

I uninstalled Internet Explorer 11 and System Mechanic works fine now.

share|improve this answer
    
IE 11 wasn't released for Windows 7 when the OP asked his question (and was never released for Windows XP) , so I don't think this answer applies to the question. – DavidPostill Mar 27 at 10:00
    
Also had this problem with IE 10 but not with IE 9 – Jac Mar 29 at 0:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.