Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After the purchase of a new Dell Vostro Laptop with Windows 7 and a nVidia GTX630M graphics chip for Christmas, I've been playing a lot of games on it. One such aspect of playing games means that I use Teamspeak 3, a VOIP application, and I do not have an external headset and as such I use the internal microphone. However, since I started using this application, my teammates have complained of a ticking noise while I am talking, much like a Geiger counter (Geiger counter noise example). I've also noticed the clicking in my microphone while recording gameplays. In one such video, i'm playing Minecraft. The video starts with me naming and creating an new world, and then playing in it. In the video, the clicking persists, even when I am not talking, however it only begins after I load the world and start the game, which is resource-intensive. When using Teamspeak, the clicking still occurs when I am in-game (again resource-intensive), however if i "tab out" and look at my desktop or other application, and then speak, the clicking dies down or stops entirely.

I have neither the money nor knowledge to test all of the end points of this problem, please help?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

This is a result of Electromagnetic interference, most likely coming from the CPU or graphics card, interfering with the analog portion of the microphone audio path (which includes the cord, the hole where you plug the jack in, and the microphone itself).

This is very common with:

  • Cheap laptops with poor EMI shielding around the built-in microphone
  • Large on-board GPUs such as that nVidia GPU you have

Remediations include:

  • Spread Spectrum settings in the BIOS may either fix or cause the problem; you can try toggling it on/off if possible to see if it helps.
  • If you are able to isolate the exact area where the EMI occurs, you can try wrapping it carefully in aluminum foil. This could involve a modification inside of your laptop case, so if you aren't comfortable with that, don't try it. It can also affect the acoustics of your microphone significantly.
  • Use an external microphone, if you're using an internal microphone built into the laptop. If you're using an external microphone already, try the one built into the laptop, or try a different external microphone, ideally with a thicker cable.
  • Use a wireless headset of some sort (Bluetooth is good). Wireless protocols communicate using digital signaling rather than analog, so they can compensate for electromagnetic interference using buffering, re-sending, checksumming, etc. (basically all the techniques that make your digital TV crystal clear and lag-free most of the time). A minor amount of interference like this won't significantly impact Bluetooth or 802.11 based wireless headset solutions, as long as it's digital (practically all modern headsets are digital of some type).
  • Use an external USB sound card or dongle, and connect it to an external microphone. This removes the entire sound chipset outside of the case, so any EMI occurring within the case shouldn't be able to penetrate the chassis of the computer, and thus you will probably get a good connection.
  • Make sure that no cables are laying on top of or touching your audio cables.
share|improve this answer
    
Using a USB based microphone is also a cheap –  Ramhound May 1 '13 at 2:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.