Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just bought an Acer Aspire S3, Intel i5 and Intel HD 4000. At first there was Windows 7 and I deleted it, then installed Ubuntu 12.10. Everything went OK and then I updated it to 13.04. Then the graphics card didn't seem to work. I uninstalled it and there was no OS on my laptop.

I don't know why, but after that I couldn't install almost any kind of Linux distribution. I've tried Ubuntu, Fedora, Mint and Arch. I think others as well.

They're all the same. I boot from USB (there is no CD-ROM), and I can see the install image. After I press Install, they all turn to a black screen. And then the CPU stops working.

How can I install Linux now?

share|improve this question
    
Not all Linux distros fail. You told us that Ubuntu 12.10 worked. –  fpmurphy1 May 1 '13 at 13:09

2 Answers 2

up vote 0 down vote accepted

Some things to try:

  • reset the BIOS. Tweak any BIOS settings which might affect this, especially the ones related to the graphics card. Try "fail-safe defaults" (or similar) in your BIOS.
  • try to install in "safe mode" if available by using a "generic" graphic driver. Dunno if this option is available for your OS/graphic card. Be careful, sometimes the driver chosen 'automatically' by the installer isn't the best one. Sometimes is better to install the bare-bone driver and after that upgrade it by hand with the latest one from the manufacturer and not from the distro.
  • try to put Windows on it again. Any Windows: XP, the original Win7 etc. It works? If yes, try to put the latest Windows HD 4000 driver for your OS. It (still) works? If not, then perhaps you have a problem with your on-die VGA and you must return your notebook.

HTH

share|improve this answer
    
Thanks. I am trying to solve it. –  zhangyangyu May 1 '13 at 7:57

Acer Aspire S3 I believe has UEFI you need to turn off secure boot.

This explains, what is UEFI? http://www.pcpro.co.uk/features/381565/uefi-bios-explained

This link will help you. http://www.zdnet.com/my-experiments-with-multi-boot-selection-with-uefi-boot-manager-7000013627/

Before I get flamed, there are many types of Linux from Arch to Zorin. Ubuntu is popular but choose one that you like.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.