Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Mac OS X 10.6.8. When I'm launching Terminal, I'm getting these messages.

How can I remove this error? I want get rid of this configuration from the bash profile.

-bash: /etc/profile.d/sm.sh: No such file or directory
-bash: /etc/profile.d/rvm.s: No such file or directory
share|improve this question
    
Which files did you edit? .bash_profile? Or did you change anything in profile.d? – slhck May 1 '13 at 9:18
    
@slhck Sorry I dont remember:( – MKK May 1 '13 at 9:31
    
Do you have backups? Did you install RVM as multi-user (i.e. with sudo)? Can you start another shell by editing the Terminal preferences and executing /bin/zsh instead, for example? If so the culprit would be .bash_profile. – slhck May 1 '13 at 10:41
up vote 2 down vote accepted

These entries are for Ruby Version Manager. Presumably this software has been removed, yet the offending statements remain in your /etc/profile - generating errors when you start Terminal.

Using your favourite editor and edit /etc/profile. Locate these lines-:

source /etc/profile.d/sm.sh
source /etc/profile.d/rvm.sh

and comment them out like this -:

# source /etc/profile.d/sm.sh
# source /etc/profile.d/rvm.sh
share|improve this answer
    
This would never be in /etc/profile unless the OP edited the file manually. – slhck May 1 '13 at 10:36
    
@MKK if the commands are not in /etc/profile then look in your home directory for the entries in .bash_profile. – suspectus May 1 '13 at 10:52
    
@suspectus Thanks so much:) It solved everything now:) – MKK May 1 '13 at 11:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .