Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Until recently (until I updated to Windows 8), I had Windows 7.

I had an *.rdp file which I could edit its session bpp value to 8, which implies using 256 colors mode when remote desktop is on.

Brief look at the RDP file:

...
screen mode id:i:1
use multimon:i:0
desktopwidth:i:1366
desktopheight:i:768
session bpp:i:8     <<-------------------(in Windows 7, this worked)
...

However, now, after installing Windows 8, this does not work and I still see my host computer in high resolution. I don't want the 15 bit. I want 256 colors.

I couldn't find any solution which is working on Windows 8.

This is the full file content:

screen mode id:i:1
use multimon:i:0
desktopwidth:i:1366
desktopheight:i:768
session bpp:i:8
winposstr:s:0,1,1136,101,1936,701
compression:i:1
keyboardhook:i:2
audiocapturemode:i:0
videoplaybackmode:i:1
connection type:i:2
displayconnectionbar:i:1
disable wallpaper:i:1
allow font smoothing:i:0
allow desktop composition:i:0
disable full window drag:i:1
disable menu anims:i:1
disable themes:i:0
disable cursor setting:i:0
bitmapcachepersistenable:i:1
full address:s:dalida.dyndns.biz:443
audiomode:i:2
redirectprinters:i:0
redirectcomports:i:0
redirectsmartcards:i:1
redirectclipboard:i:1
redirectposdevices:i:0
redirectdirectx:i:1
autoreconnection enabled:i:1
authentication level:i:2
prompt for credentials:i:0
negotiate security layer:i:1
remoteapplicationmode:i:0
alternate shell:s:
shell working directory:s:
gatewayhostname:s:
gatewayusagemethod:i:4
gatewaycredentialssource:i:4
gatewayprofileusagemethod:i:0
promptcredentialonce:i:1
use redirection server name:i:0
drivestoredirect:s:
share|improve this question
    
What OS runs on the host?? –  stijn May 21 '13 at 10:56
    
win7 32 bit tries to connect to win8 64 bit –  Royi Namir May 21 '13 at 10:57
    
Hmm, tried everything I can think of, including running an older version of mstsc from win xp, but lowest I can get it 15bit so it must be something at the host side; yet even setting HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\ColrDepth set to 1 on the Win8 machine does not do the trick.. My guess is they changed the rdp services dll so unless you find someone who can patch is I'm afraid you're out of luck.. –  stijn May 21 '13 at 12:07
    
Sorry, Royi, but if your question has not received an answer, then it didn't get enough attention, or nobody was able to find a solution for you. Unfortunately there is nothing anybody could do about this. Good luck. –  slhck May 26 '13 at 13:57
add comment

2 Answers

There appears to be a discussion on this in the a windows technet forum. The issue sounds like it might be related to a default group policy that keeps the color depth above 15bpp by default. Modifying the policy may allow for changing the color depth below 15bpp.

http://social.technet.microsoft.com/Forums/windows/en-US/1a9be361-312e-4435-a53d-f9b525bc23c3/windows-7-remote-desktop-client-cannot-set-display-at-256-colors

Also, change the rdp session to be compatible with older versions of Windows to enable the most likely to support the older color depths.

I'm interested if this helps with the problem you found but I don't have a Windows 8 system to test on.

share|improve this answer
add comment

I was able to workaround 8-bit color problem by connecting to nested windows server 2012 terminal session from another terminal session to windows server 2003 in 256 colors mode. Both servers located in the same gigabit network.

But this still doesn't resolve lags as windows server 2012 (also as windows 8) uses too many gradients in icons and backgrounds that cause everything to look ugly and work sluggish over low bandwidth remote connection.

So we need to find a way to override windows 8/2012 color scheme to be 8-bit friendly and websafe. Without this unlikely possible change, 8-bit color mode is of no use.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.