Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a webcam server that requires port forwarding to be able to access it from Internet, but the webcam server is located in a subnet and I couldn't make it work.

Description of my setup:

  1. There is a D-LINK ADSL modem router accessing Internet, its IP address of 192.168.1.1.

  2. This modem only has one output ethernet port. Currently a Ethernet cable connects this port to switch (not router, switch), a few PCs in my house connects to this switch via ethernet cable. They all have IP address of 192.168.1.x

  3. I have a D-LINK wifi router placed at the center of the house, it has Ethernet connection to the switch, it's IP address is 192.168.1.2

  4. Now anything connected to this wifi router, will have IP address of 192.168.0.x, where 192.168.0.1 is the IP of the wifi router.

  5. Now the problem is, I have a webcam server connected to this wifi router via Ethernet, it has IP of 192.168.0.50.

  6. I need to enable port forward from modem to this webcam server. Since i cant directly port flrward from 192.168.1.1 to 192.168.0.50, In my modem setup, I try to port forward to 192.168.1.2, and then on the wifi router, I try to port forward to 192.168.0.50.

Hoever this doesn't work so far. Any guides. On how can I setup this?

Screenshots of my modem router setup, I try to port forward to my Wifi router at 192.168.1.2:

D-Link ADSL Modem Router setup a.

D-Link ADSL Modem Router setup b.

Screenshots of my wifi router setup, I try to port forward to my webcam server at 192.168.0.50:

D-LINK WIFI Router setup

share|improve this question

migrated from serverfault.com May 1 '13 at 17:49

This question came from our site for professional system and network administrators.

    
Generally speaking this site is only for non-home related questions (i.e. professional / at work) But I can tell you, you probably need a router or at least route statements in your routers to route traffic from the 192.168.1.0/24 and 192.168.0.0/24 networks to each other. –  Snellgrove May 1 '13 at 14:12
    
Try to access 192.168.1.2 from one of PCs in the 192.168.1.x network and test whether you can reach the camera — this way you will test port forwarding in your wifi router without involving the modem. –  Sergey Vlasov May 1 '13 at 17:56
    
@Snellgrove what do you mean by router statements? Any further guides? I am not expert in this, i am using Dlink. Thanks! –  dunforget May 2 '13 at 3:55
    
@SergeyVlasov in my current setup, I noticed that my PC at 192.168.1.x cannot reach anything in the zone of 192.168.0.x. I cant access 192.168.0.1 for the wifi router admin page and cant access 192.168.0.x for the camera server either...thanks for the tips. So I guess I need to do something to make this work, still figuring out what to configure... –  dunforget May 2 '13 at 3:57
    
You should not be able to reach 192.168.0.x addresses from 192.168.1.x directly, because your wifi router performs NAT, so the only reachable address will be the WAN address of your wifi router, and its LAN addresses could be accessed only as defined in port forwarding rules (there might be also a DMZ option, which basically forwards all ports to the specified LAN IP). –  Sergey Vlasov May 2 '13 at 15:47
show 1 more comment

2 Answers 2

Try turning off dhcpd on your router and let the adsl modem to allocate ips.

share|improve this answer
    
Yep. Connect the router LAN-to-LAN, not LAN-to-WAN. –  David Schwartz Jun 25 '13 at 17:55
add comment

My guess that your router is blocking non routable IP addresses (192.168.1.x in your example) coming from it's WAN interface. Possible solutions:

  1. I don't know brand/firware of your router, but you could check if it has the option to allow to forward non routable IPs.

  2. Don't use separate sub-net. Use it like this:

    WAN -> router -> switch > your home network

share|improve this answer
    
Hi I would like to know how to "forward non router IPs", my modem is DLINK, wifi router is dlink too. –  dunforget May 2 '13 at 3:54
    
Your wifi router may not have these options available. Just use it as access point, the manual should explain how to accomplish this. –  user168584 May 2 '13 at 14:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.