Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a fresh install of Arch-Linux, I'm running Gnome/GDM/Nvidia proprietary driver from pacman -S nvidia

I then went sudo nvidia-xconfig and sudo nvidia-settings changed my monitor to 1920x1080, 120Hz refresh rate, but when I restart my computer it's only on 60Hz and I can't figure out why, there is no errors in the console when I hit save or anything to the config, this is the config now:

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"


Section "Files"

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "BenQ XL2420T"
    HorizSync       30.0 - 140.0
    VertRefresh     56.0 - 120.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 660 Ti"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "1920x1080_120 +0+0"
    SubSection     "Display"
        Depth       24

Any help would be great, this is extremely annoying to have to change my settings every time I reboot, thanks!

share|improve this question
Are you making the changes manually, or through the proprietary Nvidia Driver Settings binary? – Breakthrough May 2 '13 at 13:48

2 Answers 2

nvidia-settings saves its settings in $HOME/.nvidia-settings-rc. So, if you run it with sudo, it will save your changes in /root/.nvidia-settings-rc so you won't see them after a reboot.

Either edit your /etc/X11/xorg.conf manually or run nvidia-settings as your normal user.

share|improve this answer

It seems that GDM ignores Xorg configuration settings. Refer

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.