Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently installed Windows 8 on my laptop. I can display and copy/paste chinese characters fine in a web browser (e.g. textbox control) or in MS word, but in notepad or in the IE address bar they are just displayed as boxes.

In skype, I can type chinese characters OK into the input box but in the chat history area they just appear as boxes.

I have checked with a couple of colleagues and they don't have this problem. Arabic and Thai also seem to work fine for me.

share|improve this question
    
Check the Language Control Panel applet on your colleagues' PCs. What languages do they have installed? What locales do they have set? –  Karan May 3 '13 at 17:29

2 Answers 2

I discovered a suggestion here which worked a treat:

Unicode characters suddenly start displaying as boxes in some applications

Basically switch the default locale to Chinese and back to English, and everything is working now

share|improve this answer

For Win 8.1, just download the language pack.

Control Panel\Clock, Language, and Region\Language 

or

Control Panel\All Control Panel Items\Language

The window for "Change your language preferences" should display your Chinese you had added, click the "options" next to it, select "Download and install language pack". After Download and installed, restart, DONE!

Win8 let you add a language but did not tell you to download the language pack, the system couldn't found the font to display then it shows square instead.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.