Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Quite a while ago my graphic card died and I had to buy a new one. I decided for an ASUS Radeon HD 7870.

While I love the power of the graphic card and have no problems while playing games, I'm experiencing an annoying problem while I'm just on Windows with my dual monitor setup. Sometimes my mouse cursor gets broken on my main monitor and simply looks like this:

1

This seems to happen just at random situations and also sometimes when I move the mouse from one monitor to the other one. I can also always use a "workaround" to "fix" the problem, which means if I just move the mouse from one monitor to the other one often enough it becomes normal again at some point. But I don't want to do this all the time, so I'm searching for a solution.

I did a lot of Google research (try typing "ATI brok" in Google and it will already show you a lot of search entries for a broken Cursor), but the results where mostly not helping at all. Often they are "old" (from 2009 and before) and deal with mouse problems while playing games, which is not my problem. I'm missing up to date results from someone with maybe the same graphic card and can help me.

What I read some times is that deactivating windows aero should "fix" the problem, but to be honest I enjoy Windows Aero a lot and would prefer something different (I don't want to sound arrogant). The same is that some people say it would help to activate mouse trails, but the look & feel (like lagging) then bothers me even more. I also tried to disallow that the mouse cursor gets changed through designs, but this didn't change anything

Here is for example a big thread where people are talking about a similar (same?) problem. Some also state that deactivating Catalst AI would solve it for them, but I can't find this option in my up to date Catalyst Control Center anymore (maybe possible in a file somewhere in the directory of the CCC?).

Well, what's left to say is that I always keep my system up to date and already often installed new graphic card drivers (even sometimes tried Beta Versions). But the problem never disappeared.

Can someone here help me, has some ideas or experienced the same? I would be glad to hear from you! I'm also curious if this could maybe mean my graphic card is broken? (Although somehow it's hard to imagine for me)

Thanks a lot for every thought you're sharing with me.

Edit: Today it has happened again with the new ATI drivers.

share|improve this question
    
try the 13.5 beta driver: support.amd.com/us/kbarticles/Pages/…. Also try to disable the mosue shadow as suggested in the technet topic –  magicandre1981 May 4 '13 at 18:58
    
You are not alone in this! I've experienced this first time about 5 years ago on my laptop with ATI 2600 HD graphics. It happens only sometimes (sometimes after playing Global Operations) and I was not able to find any solution. Same as you with dual monitor setup and that time I was using Win Vista x64. Now I have Win 8 x64, dual monitor setup, Sapphire Radeon HD 7870 XT (this version has Tahiti GPU from 7900 series) and recently I have seen this "half-tree" again! This time it happens without any game involved... –  klerik May 4 '13 at 20:21
    
But in my case I'm experiencing also some artifacts in Firefox but it's very rarely and it involves placing (or moving) cursor on some specific places on page. I think this all is caused by malfunctioning graphics RAM but I cannot prove it. BTW everything else is working just fine – OpenCL programs, games, video playback... So as you can see, this problem is very old and I believe it's only ATI/AMD specific. The worst thing is that I cannot reproduce this problem... it just happens. –  klerik May 4 '13 at 20:21
    
tried disabling the mouse shadow, but it didn't help. I today installed 13.4 and the issue occured again. I think I will give the new 13.5 driver a try, although I'm not very optimistic. Thanks for your comment –  Waylander May 4 '13 at 20:44
    
I get broken mouse cursor after SimCity 5, with all ATI drivers I tried. My workaround is to SLEEP Windows. HW: Radeon 5770, Win 7x64. –  Hernán Mar 10 at 18:37
add comment

5 Answers

up vote 9 down vote accepted
+100

ATI drivers had mouse corruption errors since 2001.
You have already discovered almost all the existing workarounds.

You should contact their Support, and in the meantime keep on looking for driver updates. But I don't think that a 12-year problem has any hope of an early solution.

Below is the complete list of workarounds that I was able to find :

  • Enabling/disabling shadows for mouse
  • Enabling mouse trails
  • Disable Catalyst AI (through ATI Tray Tools)
  • Disable mouse shadow
  • Disable Windows Aero
  • Use a third-party cursor app (cursorFX, etc.) to draw a better cursor
  • Return the DPI setting in Windows 7 to normal (if changed)
  • Change the dual monitors positioning in Windows (use Above etc.)
  • Do not use ATI for multiple monitors

And here's a possible list of ways to "fix" the cursor without rebooting:

  • Unplugging mouse
  • Open magnifier and zoom to 100%, leaving the magnifier open
  • Activating an eyefinity profile (for those with multiple screens)
  • Changing resolution
  • Put Windows into sleep mode
  • As soon as you see the stripes/comb pointer, move the mouse to the edge of your screen (top right was mentioned) and shake the mouse a few times
share|improve this answer
    
Thanks a lot for your answer. I will check out if disabling Catalyst AI or using a third-party cursor app will fix the problem for me (mouse shadows sadly didn't). Do you have any suggestion on how I should disable Catalyst AI, since the option is gone in nowadays CCC? –  Waylander May 6 '13 at 22:59
    
Here is a link on How to disable Catalyst AI with the latest CCC. –  harrymc May 7 '13 at 6:27
    
Thanks a lot for the link. So you would say this is definately (!) no hardware issue, so my graphic card itself is not broken? –  Waylander May 11 '13 at 23:06
    
I can't of course be definitive, but the general consensus on the Internet seems to be that ATI cards are good to excellent, and it's the software that's broken. (I myself prefer Nvidia, hardware and software.) –  harrymc May 12 '13 at 6:43
    
I did take care, thanks a lot for the time you spent on this and the answers you gave :-) –  Waylander May 12 '13 at 11:25
show 2 more comments

If you're using multiple monitors you can always right click on the desktop of your side monitor(s) and the main display will be corrected again. Annoying bug but that's always fixed it for me when it appears.

Drivers will not just fix this one, I haven't had it until the 7000 series though which is extra annoying and I've been with ATI / AMD after 3DFX went out.

share|improve this answer
add comment

I've tried everything to fix this, and recently i found out the best way to fix it (Which hasn't failed at all so far) is to move the mouse to the top right of my screen and shake it around a bit. I'm so relieved i found this solution, I use 3 external monitors 7970M graphics card and moving the mouse to the top right then shaking it around would make it jump from my 2nd to 3rd monitor, after about 5 seconds at most of doing it the mouse fixes itself.

share|improve this answer
add comment

This is annoying and I've never found a solution. Had this issue since I built a new three monitor system with an ATI card a couple years ago. I do not do games nor advanced graphics so that is not the cause.

A lot of internet research has found this has gone on for years and has never been fixed - which I find incredible for a company like ATI / AMD.

None of the fixes have worked for me. But the best suggestion for a temporary fix is to click in an area in the upper right corner of the monitor showing the "comb" cursor. This always changes it back and is quicker than just moving the cursor around in any area.

share|improve this answer
add comment

Simplest and least invasive solution.

Open the "Screen Resolution" context menu by right clicking on the Desktop.

Reorder any display and apply changes. Reorder displays back to original order and apply changes.

Viola! Your cursor is back.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.