Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Windows 7 laptop with an built-in wireless NIC and USB 3G device. If the wireless network connection fails I want to automatically kick over to the 3G connection. I can have both running at the same time no problems, but whenever they are the internet connection always goes out through the 3G connection rather than the wireless. I have tried "internet options" setting, or prioritising the connections through the network and sharing center, all with no luck. I think this can possibly be achieved through the command prompt and the "route" command but I can't figure out how to do it.

Any thoughts would be much appreciated.

share|improve this question

1 Answer 1

Very interesting question so I googled around. This may not help but found this answer, quoting it:

You can try this, although I can't promise it will work every time.

  1. Open Control Panel\Network and Internet\Network Connections
  2. Right click on your 3G adapter and select properties
  3. Highlight Internet Protocol Version 4 and click the properties button
  4. Click the advanced button.
  5. Un-check the "Automatic Metric" check box
  6. Enter a value of 10 in the "Interface Metric" box.
  7. Click OK all the way out.

Now repeat the same process with the WiFi adapter, but give it a metric of 1.

What your telling Windows 7 is that given two active connections to the internet, use the one with the lower metric...in this case WiFi. This only impacts situations where both connections are active. When only one is active, it "should" use that one, regardless of the metric. I say "should", 'cause you know how it goes with windows.

share|improve this answer
    
Hi, thanks for that. Unfortunately it didn't work. For some reason it keeps favouring the 3G connection rather than the wireless. Any other suggestions would be appreciated. Thanks. –  Adam May 6 '13 at 7:19
    
Hm. Weird. Try to swap Metric values (so set 10 for WiFi, 1 for 3G and keep "Automatic Metric" unchecked of course). If anything strange happens, please post it (e.g. favors 3G but sometimes now drops conn, etc). You don't have any "tricky" on your computer, right? Like network bridge, or keep or something. –  Mark May 6 '13 at 16:57
    
It is weird, and annoying! Anyway, tried that and it didn't work either. I did notice something interesting, when I set the metric on the wifi card to 1, then go back in after a while, the number has changed to 4226. Doesn't always do it though! Overall what I'm trying to achieve is that if the internet connection via the wifi drops out it fails over to the 3G so that the laptop is always accessible –  Adam May 7 '13 at 6:26
    
I'm afraid this is getting to the "must see" point :/ But this 'effect' you describe is very strange. I think there should be another tool ""managing"" the network settings for you. Possibly the mobile provider's 3G application for your 3G dongle. Try to uninstall it and use a popular 3rd party - otherwise, I've no idea what could be going on on your system I'm afraid. –  Mark May 7 '13 at 8:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.