Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After crashing, my windows laptop stopped booting up correctly (it boot loops instead of booting into windows). I used a windows recovery disk, and saw via the console that files could still be viewed so the hard-drive is not broken.

My goal is to back up my files before attempting to fix the windows install.

I currently have Ubuntu running from a CD (version 12.04 LTS) on it, but how do I access files from the hard-drive so I can back them up?

So far I've tried fdisk -l which lists 3 partitions /dev/sda1 and /dev/sda2 and /dev/sda3 but I can't mount them (it says the device doesn't exist) and when I cd to /dev/sda they aren't listed - only sda is which also won't mount (it says it's the wrong file system type no matter which file system type I use).

How can I access the files on my hard drive?

share|improve this question
    
you may need the ntfs-3g package, depending on Ubuntu version for the partitions to mount. –  Lorenzo Von Matterhorn May 3 '13 at 1:03
    
@D0rf: I'll try that - would not having it cause the partitions to not show up under /dev/ though? I'm using the latest ubuntu release btw –  Cam May 3 '13 at 1:04
    
@D0rf: this did not work. It's still not showing up in /dev. –  Cam May 3 '13 at 5:16
    
I got a feeling that your hard disk have fail and beyond repair even though it can detect it. –  Jack May 3 '13 at 5:27
    
Maybe you can try to do a NTFS fix by issue this command sudo ntfsfix /dev/<device name> and then issue a sudo ntfs-3g -o force,rw /dev/<device name> /media/windows Let me know if it works. –  Jack May 3 '13 at 5:28

1 Answer 1

after your live CD or USB have boot successfully click on Try Ubuntu button and when it was loaded just click on the folder shape icon in the left panel (this is called Nautilus) and see if your windows drives are listed under Devices in the left pane of Nautilus. click on them and you can see/access your files.

ntfs-config is an unmaintained and obsolete piece of software and is not needed for mounting the windows partition just mount them from Nautilus.

if this didn't work run this command in a terminal and post the output so i can see if there's anything wrong with your fstab file:

$ cat /etc/fstab

EDIT:

following this tutorial should sort this out for you. it has a section for manual mounting but make sure to read it entirely.

share|improve this answer
    
That did not work. The contents are: gist.github.com/cammckinnon/5516564 - do you have any ideas? –  Cam May 4 '13 at 7:06
    
did you follow the tutorial? –  MoKi May 7 '13 at 11:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.