Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Dell Sudio 1555 with integrated ATI Radeon GPU with 512 MB dedicated (ATI Mobility Radeon HD 4500/5100 Series). I run Windows 7 Home Premium. Due to some hardware related issues (like overheating), I would like to disable my GPU (the complete graphic card), so that only CPU will be used. I disabled it from device manager, and my resolution went down to 1024x768. Is this enough? I found no option in my BIOS for disabling display adapter.

share|improve this question
    
If you disabled the device in the device manager then its disabled and no applications will be able to use it. Of course this also means you don't have any graphics device. While its strange your display even works when you disabled the GPU, your display adapter is likely handled by a dedecated part on the motherboard. –  Ramhound May 3 '13 at 13:36
    
Your GPU, while hot, is more efficient at rendering graphics then your CPU, at the same resolution. So the best solution may in fact be to lower your game resolution to 1024x768, but keep using the GPU. –  MSalters May 3 '13 at 14:03

2 Answers 2

As far as i know Core 2 Duo CPU's do not have on-die GPU's, so disabling the only GPU your system has available to it will mean: No Video...A CPU is not designed generate the video output to your screen.

By deactivating the GPU in Device Manager you're only deactivating the Driver, hence you still get Video Output at the (without a driver) possible resolution of 1024x768.

share|improve this answer
2  
That's not why. Windows has been able to run without a GPU from Windows 1.0 to XP. In those versions, the CPU could render the screen buffer, without a GPU. Sending the screen buffer to the monitor was actually done by the RAMDAC, not the GPU. Since Vista (Windows Device Driver Model 1.0), a GPU is required though. WDDM was judged too complex for a CPU. –  MSalters May 3 '13 at 14:10
    
Thanks @MSalters - nice addition. –  M.Bennett May 3 '13 at 17:07

+1 to M.Bennett.
Instead of trying to "disable things" try to figure out why the device is overheating. 99% of time it's the driver causing the issue. I'd recommend uninstalling Video Card driver (RUN appwiz.cpl, remove), then destroying it completely with Driver Sweeper as add/remove won't clean it out completely and install the latest driver from manufacturer (it is a good idea to download driver before swiping current one as you'll lose graphics quality and browsing will be a bit more difficult).
If latest manufacturer driver didn't help (most of the time it does...), look around at Guru3D for a tool to monitor and manually control GPU fans and set them to a higher default speed.
If the issue you are facing is not unique, a google foo would probably can help too to find the solution for overheating.
If none of the above helps, you need to clean your notebook as it's probably dirty (or if new, fans not working as intended) as well as keeping an eye out of the surface you use the notebook on (e.g. a friend of mine had overheating all the time and told me only after weeks he is using the notebook in his bed so he physically blocked the air vents with his cover - it's silly but hey, it happens to all of us :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.