Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have this ADSL modem/router: pirelli drg-A221g (bit.ly/107drdY) It has one RJ-11 (ADSL Phone line) input, one output to telephone headset, and only one RJ-45 (Ethernet/lan) connection on it.

It works fine, when I am using ADSL, and I can connect several devices to it wirelessly. Now, I want to disconnect it from RJ-11 (ADSL line), connect its RJ-45 (lan) to internet connection cable (from other company), and use it only as a router to access to internet wirelessly. I want to connect my internet cable (coming from TV-cable-modem-box) to this router and have wireless internet in my laptops and mobiles. But it does not work!

I connect internet cable from tv-cable-modem-box to my laptop and it works ok. Then I tried connecting this cable to the only RJ-45 port on the router. All devices successfully connect to the router, but there is no internet!

After doing several restarts in the router, laptop and tv-cable-modem-box, (only restarts, no configuration or settings), I could get internet on my laptop. But still, my other devices are connected to the router, with no internet.

Can someone help please? Thanks

share|improve this question
    
@Ramhound, I have internet connection via LAN cable. When I connect this lan cable to RJ-45 port on the ADSL Modem/Router, after some restarts, I get wireless internet in one of my laptops. But my other laptop and mobile phones, although they are connected to the same router, they do not have internet. Any solution? – cybergeek654 May 3 '13 at 13:51
    
@Ramhound DUDE it is not an ADSL modem. It is an ADSL modem/router. He said that. i.e. one of those devices that is both a router and a modem. You might've seen one, as loads of homes have one. It may even be the most common thing provided by ISPs. – barlop May 3 '13 at 14:13
1  
@cybergeek654 have you dealt with NAT and DHCP so there's no clash? Like, only one device doing DHCP, and I guess you want your modem/router device to do NAT. And you may as well have your modem/router do DHCP. – barlop May 3 '13 at 14:16
    
@Ramhound Actually, maybe some can. I think i've done it before, and the manufacturer was on the line at the time and said it might work though is not designed for that. They're not really designed for that. It can work. It's wrong to say as you did "ADSL Modem as only a router" He is talking about a modem/router device. It's a better idea to use a plain router 'cos he'd be using the device in a way not intended. I've done it before though. The LAN ports aren't obviously just "output" and they don't work like "input internet"!! – barlop May 3 '13 at 14:19
    
@barlop - The author's device can't The device in question is a ADSL modem that has 802.11 capabiltiies. Even if the device was some other device it would need a RJ-45 wired as an internet port. I made an error in my original comment. The internet is handled by the RJ-11 port not the RJ-45 port. – Ramhound May 3 '13 at 14:20

To check the settings of the router please do the following steps:

  1. First use the laptop/pc that is connected to the router either wired or wireless.
  2. Now run the command prompt and type ipconfig.
  3. You will find the default gateway displayed.
  4. Now go to the web browser and give the gateway address in the address bar. Remember that only the device that is connected to the router can access the router.
  5. Now you will see the login page which asks us username and password most likely default username as admin and password as admin but it can differ. If you can't login please search it in the google or ask your ISP.
  6. Now you can see the settings of the router.
share|improve this answer
    
Format your question, I could fix it for you, but the quality isn't that good (and doesn't say anything new) – Ramhound Mar 16 at 1:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.