Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A friend recently upgraded to a new cable internet connection. The modem connects to the router and various PCs and smartphones from her roommates connect to the router. They don't have any problem accessing the internet.

She has Windows 8 and can't access any website (via wifi and ethernet). DNS (UDP) is working, DHCP set up everything correctly, Wifi is working, Trace routes and Pings (ICMP) go through with no problem at all. But neither Dropbox nor Skype nor Spotify nor any browser (all TCP) can access any website.

The thing is though, she can connect through the university wifi and via a neighbors wifi. It's just her home connection. No firewalls are running and the computer is clean - no malware.

How could it be that only her home connection won't work and others do?

share|improve this question
    
From the sound of it, she's not getting good DNS resolver information via DHCP; if she can ping an Internet host via IP, but not by hostname, that definitely points to a DNS resolution failure. –  Aaron Miller May 3 '13 at 16:33
    
No, DNS is working, she can resolve remote host names –  entity64 May 3 '13 at 16:37
    
Huh. Time to fire up Wireshark on her PC and see what's happening to her packets, maybe? That's what I'd do next, at any rate. Unless that shows an obvious answer (RST packets coming back from the router, maybe?), I'd call the cable provider -- an unpleasant prospect, to be sure, but you seem to have done a good job eliminating anything inside the network as a possible cause. –  Aaron Miller May 3 '13 at 16:41
    
But the connection works for all other room mates and when using Linux on said Laptop, the cable provider won't be able to help. Wireshark is an option that I might have to pursue later... It must be a Windows 8 configuration error :/ –  entity64 May 3 '13 at 16:57
1  
Well the thing is, it worked fine for her on Windows 8 until they upgraded to the new cable provider. The router didn't change though, so the ISP change shouldn't have made a difference. –  entity64 May 3 '13 at 17:03

2 Answers 2

It sounds like you have tried everything, so two more steps wouldn't hurt you. First check on IE if any proxy servers are setup then please try (as administrator) to:

net stop dnscache
net start dnscache

and :

ipconfig /flushdns

With Win a reboot always helps.

Sorry I don't have any Win8 box near me to check so I do not know if it actually works.

share|improve this answer

Ok I fixed it:

netsh int ip reset c:\log.txt
netsh winsock reset

Note - in Windows 8, you need to run the command prompt in administrator mode:

Windows Button + "X"

Command Prompt (Admin)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.