Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Google's interface and search results don't always appear in my preferred language, English. I'm located in Mexico City and, although I generally have no problem with Spanish, I would prefer search results in English most of the time. (The exception is when I'm using search terms in Spanish.) I'd also prefer the interface to be in English, but that's far less important to me than search results.

Google looks at your IP to decide where you're coming from and thus what language to present results in. So, when I type www.google.com into the URL bar, it redirects me to www.google.com.mx.

Is there a way to force Google to use one language all the time?

Here are some things I've done and tried:

0) I have a Google account, and I've configured it such that it should know that English is my preferred language. I don't often explicitly log out of Google, so generally Google knows I'm me and my preferences when I access its services.

1) I've configured my browser to ask for pages in English. Very few sites support this feature at all; Google isn't one of them.

2) From www.google.com.mx, I can click on "Google.com in English". This works until, I think, I close the browser.

2a) From www.google.com.mx, I can go into account configuration, which is English. From then on, everything's in English.

3) I can append &hl=en (Human Language = English) to the end of the URLs of result pages.

2, 2a, and 3 all "work", but they're all mildly annoying. I'd rather avoid them if I could.

(At the risk of stating the obvious, English and Spanish are the languages I'm dealing with, but I imagine that, say, a francophone using Google from Korea would run into basically the same issue.)

share|improve this question

4 Answers 4

2) From www.google.com.mx, I can click on "Google.com in English". This works until, I think, I close the browser.

You have a problem with your cookies.

I'm from France, so when google.com is opened for the first time, it redirect me to google.fr. But when I click on "Google.com in english", then it stays that way (until I clean my cookies) even when I close my browser.

share|improve this answer

Change your bookmark to point to http://www.google.co.uk which should always be in English.

share|improve this answer

if you go to

www.google.com/ncr <-- no country redirect

it will stay there. Probably works for www.google.other_domains

share|improve this answer
1  
It is not working for me. I am in Luxembourg and using that URL i still got French interface. –  takacsot Feb 13 '13 at 18:15
    
@takacsot - Can't say what might be the problem. Worked for me so far. –  ldigas Feb 14 '13 at 13:07

I've been massively frustrated with the language changing across Google services. Pages would appear in Swedish regardless of my Google profile or browser settings.

I just found that setting the language in Google Search Settings magically seems to work as kind of a master switch for other Google services as well (how's that for consistency) - at least with the newest version of Chrome. Your mileage might vary, but give it a shot.

  1. Do any Google search
  2. Click on the Settings cog on far right -> Search Settings
  3. Choose a language for "Google products to use"

Setting language for Google services, through Search Settings

Be sure to also add your preferred language in Chrome's own language settings. This makes sure it doesn't e.g. offer your own language to be translated.

share|improve this answer
    
Oh, crap. I found the default language setting among my Google Account settings (what language I would like Google services to be presented in), but I would have never thought that they have a separate settings for search pages, where the term search is interpreted broadly, encompassing Maps and Play as well. Thanks for the information! I'd give it a 100 upvotes if it were possible. :-) –  David Hanak Jan 29 '13 at 9:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.