Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed the apache-tomcat server on my local win7. The port I specified is 9999.

I can access my service by http://localhost:9999 and http://myIPAddress:9999

But I cannot access my apache server from other computers. I searched on the internet, and found I should add a firewall inbound rule in its advanced settings.

  1. Right click "Inbound Rules" on the left pane
  2. Choose "New Rule"
  3. Choose "Port"
  4. Under "Specific ports" enter your port number (9999)
  5. Continue with "Next" until the end of the wizard, naming the rule when asked.

After doing this, it still doesn't work!!

Then only method I find by far is turning off my windows firewall! But this is not preferred since the potential security risk.

Some online post refers to httpd.conf file. But my apache-tomcat have no such kind of fire.

Could someone give me some hints?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

If you haven't already, make sure your modem and/or router are not blocking the connection. They have built in firewalls which will block the connections if not properly configured to allow access to your computer.

You may also want to try another firewall option such as Comodo which gives much more control over what settings/connections/programs are allowed.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.