Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Fedora 18 installed as the OS in my machine. I created a user called myworld. I installed the MapFish virtual environment and created a MapFish application. Now I tried to run that application using wsgi on httpd(Apache) server. I configured the python_egg_cache file to /var/www/html/python-eggs. When I launch the application it throws following error:

ExtractionError: Can't extract file(s) to egg cache The following error occurred while trying to extract file(s) to the Python egg cache:

Permission denied: '/var/www/html/python-eggs/psycopg2-2.0.12-py2.7-linux-i686.egg-tmp'

The Python egg cache directory is currently set to: /var/www/html/python-eggs

Perhaps your account does not have write access to this directory? You can change the cache directory by setting the PYTHON_EGG_CACHE environment variable to point to an accessible directory. I have browsed so many sites with the same issue. Unfortunately none of the solutions have resolved my issue.

later I have given full permissions(777) to that folder and still not resolved the issue.

Could any please help me in resolving the issue.

share|improve this question

You must log in to answer this question.

Browse other questions tagged .