Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I try to install or update a program which uses a .msi installer, the installation gets up to the final step and the progress bar almost reaches the end, but the install suddenly fails with an error 2503, followed by an error 2502. This happens with many different applications, including TortoiseSVN and Brackets. Strangely, uninstalling programs which use the .msi installer works fine.

Here's what I've tried:

  • Checked permissions on C:\Windows\Installer. System and Administrators all have full permissions (excluding special permissions), and Everyone can Read, List Folder Contents and Read & Execute. This is apparently the correct permissions according to sites I've found.
  • Tried temporarily removing the contents of the C:\Windows\Installer folder. No effect.
  • Tried opening command prompt as an administrator and running these commands:
    msiexec /unreg
    msiexec /regeserver

I'm using x64-bit Windows 8. Any suggestions on how to resolve this issue would be appreciated.

Update: By right-clicking on the MSI file and selecting 'Run as Administrator', the installation succeeds. However is a workaround, and I am still looking for how to solve the original problem

share|improve this question

2 Answers 2

The solution I found for a similar problem is detailed on this page http://www.energizedtech.com/2013/05/windows-installer-error-2502-a.html

Basically you use the Command Prompt as Administrator, then install your package from there. Worked for me.

Pat. M

share|improve this answer
    
This is more of a workaround then a solution. I was able to get an installer working by choosing 'Run as administrator' from the context menu as well. –  bungeshea Oct 17 '13 at 5:43
up vote 0 down vote accepted

I eventually solved this issue by preforming a refresh (keep personal files but reset Windows and programs).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.