Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have 127.0.0.1 ajax.googleapis.com in my hosts file and a script listening (and dummy-serving) on port 80. When I load http://ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js directly, Firefox loads it correctly, but when I load http://superuser.com/ (which uses jquery in a <script> element) it doesn't request the script at all (and Superuser shows the "external js failed to load" error). The weird part is that when I remove the hosts entry and load the script from 173.194.79.95, Firefox does request the script (and successfully load it, although I don't care about that).

How can I get Firefox to correctly load scripts from 127.0.0.1?

(Edit: Happens on any 127.*.*.* and with various sites and (presumably) scripts.)

share|improve this question
    
Perhaps it's not loading it because it already loaded it. –  David Schwartz May 4 '13 at 12:01
    
@Schwartz, Superuser gives me the "requires external js that failed to load" error (updated question). I'd be okay with Firefox just caching it for no good reason, since it would still have to request it eventually, but this seems to be Firefox thinking the server doesn't exist if it's hosted in 127/8. –  David X May 4 '13 at 23:18
    
If it failed to load, then it probably is requesting it. –  David Schwartz May 4 '13 at 23:28
    
Except that no connection shows up on the server script output (which does show a connection for url bar loads (and a couple of /favicon.ico loads as well)). –  David X May 5 '13 at 0:03
    
Probably a long shot, but are you using a proxy by chance? And if so, when you go into Preferences (or Options), is there anything set that matches your 127.x.x.x pattern under Advanced -> Network -> Settings -> No proxy for? –  jerdiggity May 5 '13 at 2:46

1 Answer 1

It's apparently NoScript's 'Application Boundaries Enforcer', which I just found out exists. Disabling it seems to makes the problem go away. Now I just need to figure out the most malware-hostile way of forcing it not to block jQuery.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.