Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Me and my friend have both two exact the same laptops, bought from the same shop at the same day and I decided one day to go wireless because I forgot my ethernet cable to the LAN party (with a few other laptops but this question will be specifically about these two laptops).

I downloaded connectify, a tool which utilizes the windows netsh features to create a Wireless Accesspoint from my laptop.

Both laptops have a Realtek RTL8723AE Wireless LAN 802.11n PCI-E NIC and the same, newest and updated drivers running on Windows 8 with a Core i7-3630QM (2.4-3.2ghz 8 logical cores / 4 physical) Processor and 8gb 1600mhz RAM.

From what I know the 802.11n technology has a theoretical speed limit around 300 Mbps ( 37.5 MB/s). Yet the speed achieved when directly sharing a file from the first laptop to the second laptop is 16 Mbps ( 2 MB/s ). This is an utilization of ~5% and not even near the speed of 802.11g, not to mention 802.11n...

  • Where is my remaining 95% of the speed 802.11n offers?
  • Why is the connection so slow?
  • Is the 300 Mbps speed of 802.11n just a big marketing scam?

I also tried following this tutorial but the results were exactly the same.

The gigabit ethernet works really nice, we get speeds around 75MB/s ( 600 Mbps ) [peak: 115 MB/s].

Also, please note: the laptops aren't even 1 meter from each other and no other devices were connected to the network access point.


Edit: The netsh wlan show hostednetwork command, as requested, shows:

C:\windows\system32>netsh wlan show hostednetwork

Hosted network settings
-----------------------
    Mode                   : Allowed
    SSID name              : "xxxxxxx"
    Max number of clients  : 20
    Authentication         : WPA2-Personal
    Cipher                 : CCMP

Hosted network status
---------------------
    Status                 : Started
    BSSID                  : 20:68:9d:59:65:94
    Radio type             : 802.11n
    Channel                : 13
    Number of clients      : 0

Edit2: My friend came over with his laptop and I took a screen of my laptop stuff: enter image description here And suprisingly, a screenshot from my friends laptop: enter image description here The speed stated is 54Mbps (we achieve ~28 Mbps in the screenshot), however in our driver configuration we have both 20/40mhz bands enabled and n mode too.. I cannot think of a reason why the network would choose the slower variants.

Is there a way to fix this?

share|improve this question
    
What way do you use to transfer files? Windows file sharing? FTP? HFS? –  Alvin Wong May 5 '13 at 6:25
    
plain windows shares (rmb folder ->share with ...-> everyone -> read-only -> done) –  user144773 May 5 '13 at 6:31
    
Try netsh wlan show hostednetwork on the host, what radio type and channel does it show? –  Alvin Wong May 5 '13 at 6:38
    
@AlvinWong updated the question –  user144773 May 5 '13 at 11:07
    
When you go to Network adapters and double click the adapter? There should be a field "Speed". Is it 300.0 Mbps or 54.0 Mbps? –  Alvin Wong May 5 '13 at 12:23
show 1 more comment

3 Answers

Generally speaking, using TCP-IP, you can reach 60% of the protocol speed - mainly due to wireless- and other protocol overheads.

You can see that your wireless speed is 54Mbps and you're getting 3MB/sec which equates roughly to 30Mbps - which is 60% of the protocol speed so that is about the maximum throughput you'll see.

There are several problems which could be causing your computers to not connect that the full speed of 108Mbps, 150Mbps or 300Mbps.

  • Chipset incompatibilities
  • Firmware incompatibilities
  • Incompatible Wireless settings
  • Wireless Noise

Also, you're running a "hidden" OS functionality - I'm surprised it even works.

Generally speaking the majority of chipsets out there are either Atheros-, Broadcom- or Intel based; I've never really personally seen Realtek-anything shine.

I'm fairly sure that if you both connected to a properly configured Wireless Access Point with a similar chipset, you would get better throughput; 18MB/sec will be around the theoretical maximum throughput for all Wi-Fi devices sharing the same 50 sq m or so space around you, combined, though.

share|improve this answer
    
The "killer" fact is that both the laptops are the same manufacturer,model, and shipped the same day, ofcourse to two different addresses, one to mine, the other to my friend, so.. –  user144773 Jun 5 '13 at 22:26
add comment

802.11n when used in ad-hoc mode as you are using sometimes defaults to b/g speeds.

share|improve this answer
    
I think I'm running as an Acces Point, not Ad-Hoc : Authentication : WPA2-Personal –  user144773 May 5 '13 at 12:22
add comment

Network fix

The question you ask is not an easy one to answer because there are multiple problems set forth by automatic settings the throw each other out of whack to make them more backwards compatible with older tech, off-name brands and merchandise, and lower quality middling or connection/receiver equipment that would degrade the connections. You may have N cards but use a receiver that does not too making N impossible between the two.

I've been working on this problem for a while now and have a few suggestions on to this that might help. First thing people have to know is that almost everyone on here complains about low "Home Network Speeds" Which never gets fully addressed. It's easy to understand whether from computer to computer or accessed from a mirrored point on the internet connection speeds are based on the utilization on both points not just one. You may max out your speed settings and get low settings because your friend didn't set his in a similar way for compatibility. When on the internet people believe that when it's advertised that you can get connections speeds that are gb/s and the fact is you can pay for that bandwidth and get it, BUT did the website you are accessing purchase space on a web-host that allows that kind of speeds? most likely not... It's easier to adjust this when you have access to both points.

When you are connecting between computers you have to first set the compatibility between the two then adjust the rules and speed of the connection. Many different chips have many different settings and most are set to automatic to choose systems that will easily wok with other devices around it that it communicates with. I started with transfer speeds of 85kb/s and got it tup to 2.5mb/s across my home. almost 30x faster and promise I'm a beginner and this is the tip of the iceberg on usage I've seen experts gain 23mb/s over PC2PC transfers.

THIS IS IN FIVE STEPS THAT UTILIZE ONE ANOTHER FOR ACCESS! Do them all! Last step is the key while the first 3 build the door and doorframe for this.

First thing to do is go to http://support.microsoft.com/kb/2675785#top and download and run Hotfix to fix any damage already done to the connection by any "fixes" implemented by trying to boost your speeds.

Second Turn Off Remote Differential Compression (RDC) you have to click on start button, and then go to Control Panel and click on Programs link. Under Programs & Features section, select Turn Windows Features on or off link. Uncheck Remote Differential Compression checkbox. Click OK and wait for the feature to be deactivated.

Third since your using a laptop, Open control panel go to personalization then screen saver and change power settings option, you can also find this under personalization from desktop right clicking. From there change plan settings button and click advanced power settings go to your wireless adapter settings and most laptops have the put on moderate power saving just adjust to max performance while on battery.

Fourth step has steps to it to complete the advanced settings adjustment. NOTE TO LOOK CAREFULLY FOR EACH SETTING and also some setting will be different or not even available depending on your network card brand.

  1. right click computer and click properties and access your device manager to get into network access and double click your network card not your local area connection.

  2. open the advanced settings in this menu and your going to adjust a couple things throughout to help increase your bandwidth without the crazy overhead. (Note the reason for slow connection most times is limited bandwidth and 802.11 settings that keep modes from interacting with each other such as to many "auto" settings turned on to create a natural slow default setting with stable data transfer)

  3. SO since you have a N network card we will work from here... You prolly have a A/B/G/N capable card so first disable the lower band utility settings, aka disabling A band for B/G/N. You can also disable all but N band but you wont be able to mix with older style networks until you switch back to mixed or "auto". This will keep them from being used automatically slowing speeds, this must be done on both computers.

  4. You will notice roaming preferences that most say leave alone. but I readjusted these to max bandwidth (roam description set to max bandwidth) and automatically set (decision maker for roam set to auto) themselves on this "max my bandwidth" parameter.

  5. I've found allowing bluetooth connection compatibility only affected my transfer start up not speed or duration of my transfer.

  6. Most units have power settings that have a minimize power button which you should disable. A power use button which should be enabled and sometimes a "XPRESS" setting which should be enabled. Sometime they also include an "Overdrive/Power Push" Button which should also be enabled.

  7. Most N bands are not actually pre-enabled when so I suggest looking around for these settings too to make sure it's set to "auto" or allow it to be permeable to the network bands.

  8. Select a channel the performs on the same lines such as 11-20mHz. Some channels will have a large number of users on them and you can find out what to use by going to http://www.cisco.com/go/bqm and downloading the BQM application that they have for network performance and speed adjusting

  9. Select all band capabilities across mixed frequencies the setting should look like A/B/G/N:20/40mHz which helps to enable transfers without limitation of network frequency or band.

  10. Select Large Send Offload V2 (IPv4) and set the value to disabled and do the same for Large Send Offload V2 (IPv6) if it is available.

  11. Increase your output and input packet sizes to the max 2346. This can be called the buffer size of the files on some cards.

  12. Allow for mixed band usage over "auto" if possible even if you disable A band.

5th and final before the reboot is going into your advanced system performance settings under my computer preferences. Under advanced performance system settings you want to increase the min. paging size of the drive you will be using to 2048 and a max of 1/3rd of available space during your sharing sessions. This allows the computer to use it's self in data transfer rather than your RAM through the file transfer limiting the overhead that it causes in the 32 to 64 mb/s page speed most SATAs pull the drive to the cards at.

Finally restart both computers that you are accessing from each other

to boost this even more your correct you'll use a wired connection for the fastest possible with little packeting overhead time in your way. Even one wired over another will bypass one less reference point and use the router as the adapter for wifi. But a max of 32mb/s wireless can be achieved and the transfer is usually moving 15-20% than it admits if you do the math on a transfer versus size equation.

For better overall understanding of the subject of network data latency visit: http://smutz.us/techtips/NetworkLatency.html

You may have to force the taskoffloading to disable by Open the CMD window with Administrator privileges and copy the following commands one by one:

netsh interface tcp set global rss=disabled

netsh interface tcp set global autotuninglevel=disabled

netsh int ip set global taskoffload=disabled

Note:

To paste in CMD don't press Ctrl+V, but right-click in the CMD window, then select Paste.

Press Enter after each command.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.