Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently on my notebook's brightness stopped working. Pressing FN+F5/F6 shows the Windows 8 brightness slider, and it goes up/down, but doesn't adjust the actual brightness. Changing it manually through the control panel does not help either.

I had updated my display drivers a few days before, so it is possible that the update broke it, but I don't know for sure. I did a driver rollback, and now the problem has changed a little bit. Now, if the slider is on 50%-100%, the actual brightness is 50%. If the slider goes below 50%, the screen goes black.

I just installed the latest display drivers but the problem remains. I have an ASUS PRO64JQ, installed Windows 8 (64-bit) on it. It has an ATI Mobility Radeon HD 5730 Graphics card.

What should I do? Is this a hardware problem or a software problem? Could my adapter/battery be the problem here? I'll try to install an older version of the drivers if someone can tell me where I can find those.

share|improve this question

2 Answers 2

If this issue happened due to driver corruption after update, try performing a system restore to an earlier restore point before the issue encountered. In order to perform system restore,in the search box, type System Restore, and then, in the list of results, click System Restore.‌ Administrator permission required If you're prompted for an administrator password or confirmation, type the password or provide confirmation. Then select a earlier restore point and proceed to restore.

share|improve this answer

You have to download the appropriate drivers for your laptop. I had the same problem and installing them worked for me.

Go to Asus' download site and look for the download / install all the drivers under Utility starting with ATK. I think the ones you need are ATKACPI Driver, ASUS Configuration Utility, ASUS ATKOSD2 Utility.

The same thing applies to hotkeys problem if you have or any other functionality. If installing all these don't work, try updating your BIOS using the files on the same page, under the BIOS category. You must download the latest version, place it on a HDD partition or USB, go to BIOS, look for BIOS Flash and locate the file then install.

Most likely it's a driver not a hardware or BIOS problem.

Note: You can install the Windows 7 64-bit drivers, they worked perfectly for my Asus K50AB.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.