Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

trying send mail via sendmail forward to cf16r@wp.pl, my domain is dorotamama.eu. and I get following:

May 6 17:55:47 myubuntu sm-mta[3856]: r46FrhNl003854: to=cf16r@wp.pl, delay=00:02:03, xdelay=00:00:01, mailer=esmtp, pri=91761, relay=wp.pl.dorotamama.eu. [89.75.41.50], dsn=5.3.5, stat=Local configuration error May 6 17:55:47 myubuntu sm-mta[3856]: r46FrhNl003854: r46FtlNl003856: DSN: Local configuration error May 6 17:55:48 myubuntu sm-mta[3856]: r46FtlNl003856: to=, delay=00:00:01, xdelay=00:00:01, mailer=esmtp, pri=60000, relay=gmail-smtp-in.l.google.com. [173.194.70.27], dsn=2.0.0, stat=Sent (OK 1367855748 i8si29208219eem.229 - gsmtp) May 6 17:55:48 myubuntu sm-mta[3856]: r46FtlNl003856: to=root, delay=00:00:01, xdelay=00:00:00, mailer=local, pri=60000, dsn=2.0.0, stat=Sent

gmail No PROBLEM, wp.pl PROBLEM. additionally here from mail.err:

May 6 17:55:47 myubuntu sm-mta[3856]: r46FrhNl003854: SYSERR(root): wp.pl.dorotamama.eu. config error: mail loops back to me (MX problem?)

so I tried cf16r@wp.pl (it is correct address) but it concatenates to be: cf16r@wp.pl.dorotamama.eu. ?????????

why? other domain are working OK. (at least few that I checked till this moment)

DEBUG:

echo '3,0 cf16r@wp.pl' | /usr/sbin/sendmail -bt -d8.20 dns_getcanonname(myubuntu, trymx=1)

dns_getcanonname: trying myubuntu.chello.pl (AAAA) NO: errno=0, h_errno=1

dns_getcanonname: trying myubuntu.dorotamama.eu (AAAA) NO: errno=0, h_errno=4

dns_getcanonname: trying myubuntu.dorotamama.eu (A) YES

dns_getcanonname: myubuntu.dorotamama.eu

_res.options = 812c3, HasWildcardMX = 0

ADDRESS TEST MODE (ruleset 3 NOT automatically invoked)

Enter ruleset address

canonify input: cf16r @ wp . pl

Canonify2 input: cf16r < @ wp . pl >

dns_getcanonname(wp.pl, trymx=1)

dns_getcanonname: trying wp.pl. (AAAA)

NO: errno=110, h_errno=2

dns_getcanonname: trying wp.pl. (A)

NO: errno=110, h_errno=2 dns_getcanonname: trying wp.pl. (MX)

NO: errno=110, h_errno=2 dns_getcanonname: trying wp.pl.chello.pl (AAAA)

NO: errno=0, h_errno=1 dns_getcanonname: trying wp.pl.dorotamama.eu (AAAA)

NO: errno=0, h_errno=4 dns_getcanonname: trying wp.pl.dorotamama.eu (A)

YES

dns_getcanonname: wp.pl.dorotamama.eu

Canonify2 returns: cf16r < @ wp . pl . dorotamama . eu . >

canonify returns: cf16r < @ wp . pl . dorotamama . eu . >

parse input: cf16r < @ wp . pl . dorotamama . eu . >

Parse0 input: cf16r < @ wp . pl . dorotamama . eu . >

Parse0 returns: cf16r < @ wp . pl . dorotamama . eu . >

Parse1 input: cf16r < @ wp . pl . dorotamama . eu . >

MailerToTriple input: < > cf16r < @ wp . pl . dorotamama . eu . >

MailerToTriple returns: cf16r < @ wp . pl . dorotamama . eu . >

Parse1 returns: $# esmtp $@ wp . pl . dorotamama . eu . $: cf16r < @ wp . pl . dorotamama . eu . > parse returns: $# esmtp $@ wp . pl . dorotamama . eu . $: cf16r < @ wp . pl . dorotamama . eu . >

so, does it means wp.pl wasn't resolved?

additionally:

dig @192.168.1.1 fghj.com

; <<>> DiG 9.9.2-P2 <<>> @192.168.1.1 fghj.com
; (1 server found)
;; global options: +cmd
;; connection timed out; no servers could be reached

and +tcp:

dig @192.168.1.1 fghj.com +tcp
;; Connection to 192.168.1.1#53(192.168.1.1) for fghj.com failed: connection refused.
share|improve this question
    
1) Do you have any wildcard DNS records? [ *.dorotamama.eu ] 2) What is reported the following command executed by root? echo '3,0 cf16r@wp.pl' | /usr/sbin/sendmail -bt -d8.20 –  Andrzej A. Filip May 6 '13 at 18:37
    
where do I have to search for this wildcard? –  AB_ May 6 '13 at 19:00
    
Could you post REAL domain name? On my host nslookup -type=ns dorotamama.eu returns NXDOMAIN (no such domain). –  Andrzej A. Filip May 6 '13 at 19:06
    
I have added these options to sendmail.mc because seen somewhere might help, but maybe this is actually source of problems? >>> FEATURE(always_add_domain')dnl MASQUERADE_AS(dorotamama.eu')dnl FEATURE(allmasquerade')dnl FEATURE(masquerade_entire_domain')dnl FEATURE(masquerade_envelope')dnl FEATURE(accept_unresolvable_domains') –  AB_ May 6 '13 at 19:13

1 Answer 1

Your problem may be solved by adding WorkAroundBrokenAAAA to sendmail's ResolverOptions.

1) Check your current resolver options

grep  ResolverOptions /etc/mail/sendmail.cf

2) Add the line below to your sendmail.mc and generate new sendmail.cf

define(`confBIND_OPTS',`WorkAroundBrokenAAAA')

3) Repeat the test

echo '3,0 cf16r@wp.pl' | /usr/sbin/sendmail -bt -d8.20

4) Check your new resolver options

grep  ResolverOptions /etc/mail/sendmail.cf

5) Restart sendmail daemon/service or make it reload configuration

share|improve this answer
    
thanks very much, but didn't help. I added this: define(confBIND_OPTS',WorkAroundBrokenAAAA')dnl to sendmail.mc, no change –  AB_ May 7 '13 at 15:24
    
What is reported by grep ResolverOptions /etc/mail/sendmail.cf? What is reported by echo '3 cf16r@wp.pl' | /usr/sbin/sendmail -bt -d8.20? –  Andrzej A. Filip May 7 '13 at 16:30
    
the same as before. Option is added, sendamil recompiled, deamon restarted. Still can't find and ends with wp.pl.mydomain.eu YES –  AB_ May 7 '13 at 16:59
    
grep ResolverOptions /etc/mail/sendmail.cf O ResolverOptions=+WorkAroundBrokenAAAA –  AB_ May 7 '13 at 17:02
    
Ask your question at news:comp.mail.sendmail . include results produced by echo '3 cf16r@wp.pl' | /usr/sbin/sendmail -bt -d8.20 –  Andrzej A. Filip May 7 '13 at 18:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.