Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having problems getting Samba sharing working on a fairly stock version of Debian (technically Raspbian, but that's not all that different from Debian.) The Samba logs are giving me errors like the following:

[2013/05/05 04:07:39.988912,  0] smbd/service.c:995(make_connection_snum)
  Can't become connected user!

And this is when I'm just trying to connect to it by doing smbclient \\localhost\extrastorage (which gives me the error tree connect failed: NT_STATUS_LOGON_FAILURE.)

I know that it's available because I can run smbclient -L localhost and get the following:

Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.6.6]

        Sharename       Type      Comment
        ---------       ----      -------
        print$          Disk      Printer Drivers
        extrastorage    Disk      Place to store stuff
        IPC$            IPC       IPC Service (raspberrypi server)
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.6.6]

        Server               Comment
        ---------            -------
        RASPBERRYPI          raspberrypi server

        Workgroup            Master
        ---------            -------

So it's clearly there, and it's not a problem with the password either.

Maybe there is something wrong with my smb.conf, but I'm not seeing it:

        server string = %h server
        map to guest = Bad User
        obey pam restrictions = Yes
        pam password change = Yes
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
        unix password sync = Yes
        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 1000
        dns proxy = No
        usershare allow guests = Yes
        panic action = /usr/share/samba/panic-action %d
        idmap config * : backend = tdb

        comment = All Printers
        path = /var/spool/samba
        create mask = 0700
        printable = Yes
        print ok = Yes
        browseable = No

        comment = Printer Drivers
        path = /var/lib/samba/printers

        comment = Place to store stuff
        path = /mnt/extrastorage
        valid users = pi
        admin users = pi
        guest ok = Yes

Why am I not able to browse the shares?

share|improve this question

migrated from May 6 '13 at 17:54

This question came from our site for system and network administrators.

We don't generally consider RP systems to be servers within the scope of our FAQ. Super User or even [U&L] may be a better place to ask. – Iain May 5 '13 at 9:34
True, but this question seemed to be more of a Samba issue than anything else. I just wanted to give a complete picture of my set up. – supercheetah May 5 '13 at 9:37
You did read the faq and tour didn't you? In particular the bit about being a site for professionals ? – Iain May 5 '13 at 9:46
So, I'm not using it in that particular context here, but I could have asked the question omitting that particular detail to get to the same conclusion, right? – supercheetah May 5 '13 at 9:52
That's really not the pint though is it. If you choose to lie about your environment and get caught out the community will take a dim view of this. Better to ask your questions in the correct context on a site that is perfectly adequate for the non professional user. – Iain May 5 '13 at 10:00
up vote 4 down vote accepted

I actually figured out the problem just now. I had to install the package samba-common-bin and run smbpasswd -a pi.

share|improve this answer
After an update I also ran into this issue - having already run smbpasswd -a user before it was now sufficient to run smbpasswd -e user to re-enable the account – Tobias Kienzler May 4 '14 at 8:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.