Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

It's the same access point (wireless) and same ISP connection. However, if I'm connected to router #1, I can't see any content on Router #2 on the local network. Is there a way to fix this? It cripples my ability to stream. :)

share|improve this question
    
Use the second router as (or replace it with) a switch or access point, leave its WAN side unused. –  Marcks Thomas May 6 '13 at 22:36
1  
Can you explain your setup? You have one access point and two routers? What are those routers doing? And are the routers bridging? If so, how? WDS? Which device is the DHCP server or do you have more than one DHCP server? Which device is doing NAT or are more than one? –  David Schwartz May 6 '13 at 22:59
    
@DavidSchwartz I've got a Rogers Modem (Hitron) / Router hybrid and what appears to be this router. bestbuy.com/site/… Someone else configured it - so I'm not sure how it's setup currently. I can't access the Netgear as the PCs I've tried all seem to access the rogers modem via the gateway URL. –  Vaughan Hilts May 6 '13 at 23:02
    
I'll also note we have one access point - wireless devices are fine it's jsut some of the ethernet devices are plugged into the netgear. Those can't see the ones on the rogers modem. –  Vaughan Hilts May 6 '13 at 23:03
    
@VaughanHilts: It sounds like someone set you up with multiple LANs for some reason. –  David Schwartz May 6 '13 at 23:09

2 Answers 2

up vote 0 down vote accepted

I'm assuming your second router (the one that doesn't connect to the Internet) is wired to the other router by a LAN-to-WAN connection. This is the problem -- you should not connect a LAN port to a WAN port (other than connecting a router to a modem) unless you have a very unusual reason to do so.

Here's the fix:

  1. Log into the second router and disable its DHCP server.

  2. Move the connection to the first router from the second router's WAN port to one of its LAN ports.

  3. Do not use the second router's WAN port, the second router is not connected to a WAN.

  4. Make sure the second router's LAN port IP address assignment does not conflict with the first router's LAN IP assignment. The best IP to assign is one inside the first router's subnet but outside its DHCP range. (Or you can just hope this won't be a problem. Or change it to something unlikely to conflict like 192.168.205.1)

  5. If you know how to do a DHCP release/renew on each computer connected to the second router, do so. Otherwise, reboot each machine connected to the second router.

share|improve this answer
    
Worked a treat, thanks for saving me some money on a switch. :) –  Vaughan Hilts May 7 '13 at 12:16

You can just pick one router as primary (the more powerful one), and setup the other one in bridge mode. Every device attached to both routers will be in the same local network.

share|improve this answer
    
How would I do this? When I go to my Gateway URL, all I see is my Rogers box web UI. –  Vaughan Hilts May 6 '13 at 22:54
    
Each router will have its own configuration URL. You should look at the manual of them. –  hvtuananh May 6 '13 at 22:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.