Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows 8 installed on a GTP formatted 120 GB SSD, and it runs the OS fine with just that. Connecting my old MBR formatted 320 GB HDD as well shows in the BIOS, but Windows 8 will not load its contents or show me the drive's properties (although it shows in an Explorer window as drive D). Could there be something wrong with my HDD, or does Windows 8 not play nice with a drive setup like this? My motherboard is a Gigabyte gigabyte 990fxa-ud3 and I am booting with EFI, if that information helps.

share|improve this question

2 Answers 2

Booting in UEFI mode only works for GPT drives, that why you can't boot the MBR disk. To boot it you have to change the UEFI mode back to legacy to enable BIOS emulation.

share|improve this answer
    
Ok, that makes sense. But, if I change it back to legacy then won't the OS not start up at all because it's GPT? (I'm not trying to boot from the SATA HDD, just use it as a slave for storage, so the only bootable drive would be the SSD) Is there any way I can change the secondary HDD to GPT at this point? –  starmandeluxe May 7 '13 at 4:50
    
in this case you should see the HDD in Windows but not in the Bootoptions. Run the diskmanagement and look if the drive is not online or has issues. Also try to assign a different drive letter- –  magicandre1981 May 7 '13 at 5:40
    
A clarification from starmandeluxe: Do you want to boot an old installation of Windows from the 320GB disk, or just use it as a data disk from the Windows 8 on the 120GB SSD? If the former, then magicandre1981's answer is correct; but if the former, it's not. Windows booted in EFI mode should be able to use an MBR disk with no problems. If your problem is with the disk as a data disk, then I'm not sure what the cause is, although I'd speculate that it has to do with drivers for whatever interface you're using. Maybe changing to another connector on the motherboard would help.... –  Rod Smith May 7 '13 at 15:48
2  
Ok I have tested the drive and there was an actual problem with it. Not sure of the technical details but I ran a chkdsk /F and that fixed it. Thanks everyone. –  starmandeluxe May 9 '13 at 6:39
1  
ok, post your reply as answer and mark it as answer. –  magicandre1981 May 9 '13 at 6:51
up vote 0 down vote accepted

It turns out there was an issue with the drive itself. I had to test it by using an external USB-Sata connector for the drive to see that it was the drive itself causing the issue, not the motherboard or the OS (loading it into another computer would also have verified this test). So to resolve I just did "chkdsk /F" which fixed some problems on the drive and it is now usable again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.