Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I would like to be able to access my apache webserver from outside of my LAN. I have my config files setup so that I am able to access my server through localhost/ and localhost:8181/ (all I did was add 'Listen 8181' in ports.conf) when I'm connected to my LAN.

My apache web server is hosted on a VirtualBox machine with Ubuntu. The virtual machine's network settings are set to 'Bridged Adapter' and is attached to my wireless adapter. I am able to access the web server from other machines within my LAN (virtual machine, host computer, phone).

Ideally I would want to just use the external IP with port 8181. So I would be able to just enter 123.456.7.89:8181 and access the home page. I am not concerned with a domain name as of yet. My end goal is just to have something only a few people can access. Also if anyone has any good information on web server security as I'm sure it will be a good next step for this endeavor.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

You just need to forward port 8181 on your router to your server.

share|improve this answer
    
I tried forwarding port 8181 to the server. I also tried forwarding port 8181 to server port 80. Still unable to access it. I have also restarted the apache service after each change. Could I be missing something in my config files? –  slashoofpez May 7 '13 at 7:06
    
I have absolutely no idea why that would not work. –  ohope5 May 7 '13 at 7:14
    
Could my service provider possibly be blocking this access even though I am forwarding it? –  slashoofpez May 9 '13 at 4:50
    
This may be the case. Just checking though, might you have a dynamic ip and it has changed? –  ohope5 May 9 '13 at 6:04
    
My external IP seems to remain the same. At least it's been the same for the past couple months. I did manage to get this to work. I had to set my network settings for my virtual machine to be attached to 'NAT' instead. Then I had to forward ports from my router to my host comptuer. Then set inbound rules on my Windows Firewall. Then finally set port forwarding for my virtual machine to point to whatever ports I needed for the apache server. Meh, I should probably document this... But yeah you were correct, I just had to forward ports on my router. I just had my settings wrong. –  slashoofpez May 9 '13 at 8:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.