Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I needed to change the access rights to the system log on two computers (both running Windows 7), as described in this question. I did it successfully on one of the computers.

On the second one, I started regedit.exe as administrator from the context menu. It did not ask for a password on start, although I was logged in as a non-administrator. I added the user and groups I needed to the access list, then I clicked "Apply". I got an "access denied" error message with just an "OK" button, and there was no UAC prompt where I could have given an admin password (or possibly a domain admin password - one of the accounts which needs access came from the active directory) to resolve the issue.

When I log in with my administrator account, the same thing happens - regedit starts, but it will not let me add user permissions, not even for local accounts.

What could be causing this, and how do I add the users?

share|improve this question
What does the current Access control list look like? Who has which rights? Are you sure you are logged in as a local admin!? – Werner Henze May 7 '13 at 7:49
Are you logged in as Administrator or just as an administrator? If the latter, try doing “Run as Administrator”. – Scott May 7 '13 at 21:24
It is the second, and this is exactly what I did - by "started regedit as administrator from the context menu" I mean that I chose "run as administrator" from the context menu, and no matter which account I was using - with or without local administration rights - I never got an UAC prompt. – Rumi P. May 13 '13 at 10:16
By the way, we were able to edit the registry after somebody logged in with an account with domain administration rights. I will leave the question open, because we never found out what prevents the UAC from appearing. – Rumi P. May 13 '13 at 10:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.