Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an ftp server setup using FileZilla Server and 5 application servers which each have a backup folder that is shared.

On the ftp server I have setup symlinks in the root ftp directory that point to each of the backup directories. When using Windows Explorer I can navigate between each of these network locations via the symlinks, add, modify or delete as I please.

However, when I connect to the same location using an ftp client, the symlink folders are visible; appserver01backups, appserver02backups, etc. but when they are opened they are listed as empty directories.

Can anyone help resolve this or think of a better solution to be able to access multiple network shared folder locations from a single point of access e.g. ftp.

share|improve this question
    
what's the operating system of the server? –  golimar May 7 '13 at 9:19
    
All servers are running on Windows Server 2008 R2 SP1 –  Ghandi Manning May 7 '13 at 9:37

2 Answers 2

up vote 0 down vote accepted

Access to the networked locations were being authenticated against the service account used to run the FilZilla service.

I switched this to an account that has permissions to access the networked location.

Being a non-domain environment, this was duplicated accounts with the same username and password on both the ftp server and all source application servers.

share|improve this answer

One option since you aren't using Active Directory would be to use public keys with Filezilla. Server 2008 also supports SFTP but I haven't played with it much as I usually use dedicated SSH products for the clients that I support.

You could then generate your key pair(s), put the public key on the destination server and then use the private key to establish the connection using your preferred method of transfer (SFTP, SCP.)

Then you can just write a script in your preferred scripting language and execute via a scheduled task.

share|improve this answer
    
This sounds like very good advice for providing a secure SFTP connection and possibly automating data transfer, but it doesn't directly solve the problem described. I have managed to resolve my issue however which was related to the service user described in my answer. Thanks. –  Ghandi Manning May 8 '13 at 16:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.