Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to use tmux with console vim having solarized colors on OS X, but the colors are broken inside tmux. There are quite some questions/answers and blog posts about that topic, but solutions sometimes even contradict each other and non worked for me. As questions and blog posts are also dated, it's hard to figure out which versions have been used, ...

Can somebody specify a working solution for my requirements? I don't have any special requirements on my terminal emulator, so I'm open to use whatever works with tmux and vim.

share|improve this question

migrated from May 7 '13 at 10:06

This question came from our site for professional and enthusiast programmers.

might be a good idea to provide some of those links, or listing the techniques you've tried, so that answers don't end up referring to something you've already tried. – jpaugh May 7 '13 at 10:26
I have a problem that I won't describe and I've tried many solutions that I won't describe either. Could someone help me? – romainl May 7 '13 at 19:58

Given a lack of provided details in the question, I will post what I did with my setup to have things work 'correctly' with iTerm2 + ssh + tmux + WeeChat/Vim

I have found that the soloarized 'presets' for iTerm2 do not play nice with 256 colors, besides the main 16 it uses.

To fix this (mostly) I use Solarized High Contrast Dark instead.
This makes 256 colors work, although slightly 'off'.

After using the High Contrast version, I chose to disable the solarized.vim plugin, as it no longer looked right. (In addition, If I don't have access to solarized on a workstation, it might look off anyway; so more compatibility!)

All the above is with my $TERM and programs set properly, and not forced with an over-riding export. iTerm2 reports xterm-256color, tmux is set to screen-256color

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .