Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So this is probably one of the weirdest PC issues I have ever experienced. I built my PC in the winter of 2011, so about 1.5 years ago. Here are the stats:

  • ASUS P8P67 (REV 3.1) LGA 1155 Intel P67 SATA 6Gb/s USB 3.0 ATX Intel Motherboard
  • EVGA 012-P3-1570-AR GeForce GTX 570 (Fermi) 1280MB 320-bit GDDR5 PCI Express 2.0 x16 HDCP Ready SLI Support
  • CORSAIR Enthusiast Series CMPSU-850TX 850W ATX12V v2.2 / EPS12V v2.91 SLI Certified CrossFire Ready 80 PLUS Certified
  • Intel Core i7-2600K Sandy Bridge 3.4GHz (3.8GHz Turbo Boost) LGA 1155 95W Quad-Core Desktop Processor
  • Crucial M4 CT128M4SSD2 2.5" 128GB SATA III MLC Internal Solid State Drive (SSD)
  • G.SKILL Ripjaws Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory (2x)
  • ASUS DRW-24B1ST/BLK/B/AS Black SATA 24X DVD Burner
  • OEM COOLER
  • MASTER Hyper 212 Plus RR-B10-212P-G1 "Heatpipe Direct Contact" Long Life Sleeve 120mm CPU Cooler Compatible

It's running Windows 7, fully updated, and the fully updated FREE version of AVG Virus Protection (for which I ran a full PC scan two days ago).

The issue is very weird. I'll boot up my PC and start to do some work. Here's what usually happens, in steps.

  • Within about 15 minutes (this varies), all of a sudden it will look like the internet stops working (links don't open, new tabs don't load Google, etc.) The internet is fine. Wifi works on my phone, Netflix, etc. elsewhere - plus I'm connected directly through ethernet.
  • After this, and some clicking around to try and get things to load, the Windows 7 quick start menu stops to work. Hovering over the start menu icons does not outline them, clicking them does nothing, etc.
  • After this, the mouse changes to a loading animation over each and every window that is still running (usually I can see this by hovering the mouse over CPU Temp)
  • Once this happens, I'm boned. I can't open or close anything. Even CTRL-ALT-DEL just hangs there spinning and says it's trying to load up the options for forever.

The mouse is available throughout all of this, and performing a hard shut down-reboot will enter into this same loop of events within a period of about 15 minutes of everything working fine first. Like I said, I did a full virus scan the other day and nothing came up - 0 threats. Any ideas what this could be or what I should check? Has anyone seen something like this happen before?

share|improve this question

closed as too localized by techie007, Brad Patton, Marcks Thomas, Nifle, Renan May 8 '13 at 13:39

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
It could be a virus, but then this same thing for some reason happens to my mac after about 2 hours of usage and I have checked it thoroughly. –  ohope5 May 7 '13 at 13:40
    
Yeah it screamed virus to me because of the way it manifested itself so randomly. One day I tried to take my PC off standby and it threw some ieexplore.exe error and some other error I noted down at home, both of which I'd never seen before. Then this started to happen. –  Scott May 7 '13 at 13:45
1  
Have you tried booting a live linux disk such as Ubuntu and tried using the system with that? If the same issue happens I would have though it would be a hardware program. –  tombull89 May 7 '13 at 13:54
1  
@Scott At the software level, this occurs when a kernel thread is stuck in the "running" state and won't relinquish control to the operating system on a blocking I/O operation. The causes of this are myriad; it could actually be purely a software problem. Or it could be hardware. See my answer for details. –  ÃŁŁǫǛȉЖΦΤїҪ May 7 '13 at 14:00
1  
Please join us in Root Access if you wish to discuss this issue in depth, rather than generating large number of Comments. Thanks. –  ÃŁŁǫǛȉЖΦΤїҪ May 7 '13 at 14:01
show 6 more comments

2 Answers

Yes, I have seen this happen before.

In my opinion, the most likely culprit is a failing hard drive or SSD. Or, you could be victim of the P67 chipset (Cougar Point) SATA bug. Anandtech describes it well.

The long and skinny of it is, if you are using the SATA 3 Gb/s port on your motherboard, your SATA chipset would be expected to start to fail after a year or two of use, so you're right in the expected failure interval at 1.5 years. Even if something else than your primary disk is connected to this port, you may still get OS freezes, because it is attempting to access that device and failing. Note that "eSATA" devices were also connected to the 3 Gb/s controller on this motherboard, if I recall correctly. Your DVD Burner could also be connected to it.

Softpedia tells you to how to find out if you have an affected motherboard with the SATA chipset flaw. (basically, connect any storage device to the SATA port and run wmic idecontroller get deviceid, if it returns REV_04 then you are affected).

If you are not affected by the SATA chipset PLL leakage flaw, as determined by running the command line indicated by Softpedia, you should move on to other troubleshooting steps:

  • Run a tool such as gsmartcontrol to check the SMART status of all of your SATA devices.
  • Update your motherboard BIOS to the latest.
  • Update your chipset drivers, graphics drivers and everything else you can find (these days you can sometimes even update the firmware on your hard disks or SSDs, and graphics cards!)

Other simple steps you can try include ruling out software.

To rule out software, attach a USB flash drive or hard drive with a Linux distribution, such as Ubuntu, installed on it. Use that as your primary system for a while and see if it freezes up in the same way. Make sure you attempt to access files on your primary hard drive while using Ubuntu, just to exercise a similar usage pattern as your Windows would.

If the Linux distribution operates correctly after some time, then it is a software problem, and I would recommend reinstalling Windows as a catch-all. If the Linux distribution exhibits similar failure symptoms, it is definitely hardware.

share|improve this answer
    
Thanks so much for the great answer. I will work through these steps when I get home from work today and update you. –  Scott May 7 '13 at 14:02
    
OK. I've made some of the regulars in Root Access aware of this question, so even if I am not personally available to help you when you get home from work, feel free to drop by the chat and ask for help if you get stuck. This type of question is really best resolved in chat because the method of resolution is "try a bunch of things"; there's not really a clear answer that we can point out a priori. It may even be that nothing I've posted in this answer is applicable to your situation. –  ÃŁŁǫǛȉЖΦΤїҪ May 7 '13 at 14:08
    
The SATA2 bug should not be an issue in this case - the ASUS P8P67 V3.1 board should be using the B3 stepping (as per the spec page), which resolves this issue, though it won't hurt to check - Asus has some instructions here too. –  Bob May 7 '13 at 18:19
    
Trying another operating system may work, but attaching and running it from a different drive may hide a hardware issue with the primary drive, so keep that in mind. Also, it may be a hardware issue exposed or made more obvious by how one operating system interacts with the hardware. Still a good test, but keep in mind that it does not necessarily rule out hardware (though, of course, it does work to confirm that it is the hardware...) - only rigorous hardware stress tests can really do that, and even then it's uncertain. –  Bob May 7 '13 at 18:22
add comment

I have seen situations like this under W7 (64 bit) with vssvc.exe or other MS antivirus programs taking up most of the CPU (one core to be exactly, the second core was assigned to a virtual machine).
This was either shortly after machine start or after a MS signature file update. Looks like it's scanning and not behaving properly. After 5-10 minutes the machine came back.

share|improve this answer
    
The author doesn't have any MS antivirus programs installed except Windows Defender which is only ran by default when an signature update is released. –  Ramhound May 7 '13 at 14:36
    
I was not specific enough in my original answer. On my machine this sometimes happens with msmpeng.exe (Defender) and often with vssvc.exe, which he both has. –  Jan Doggen May 7 '13 at 14:42
    
vssvc.exe is only running if he has his installation to create shadow copies of his files turned on. –  Ramhound May 7 '13 at 14:59
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.