Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We have 3 laptops (Dell, Gateway, and MBP) in the house running on a wireless network.

I have gone through a netgear, smc, linksys and now dlink router (exact same issue on all) and whenever we all want to connect the last person to connect wins the connection rights and everyone else has to reset their laptop's wireless card to gain access again.

Is there a way to stop this from happening other than assigning each computer their own IP Address?

It seems as though we all compete for the 192.168.0.100 address.

share
    
Since you changed out the routers, that seems to indicate the problem is the configuration of the laptops, not the routers. Sorry I couldn't help more. –  davr Oct 23 '09 at 5:50
add comment

4 Answers

up vote 4 down vote accepted

I do not believe that you're really using DHCP, if you're all competing for 192.168.0.100. Or else the router gave you all a long-life lease on 192.168.0.100.

Here is a checkup list for verifying the settings:

I suggest on each of your machines, to go to Network Connections / Local Area Connection / Properties, uncheck IPv6, go to IPv4 / Properties and make sure to check both "Obtain an IP address automatically" and "Obtain DNS server address automatically".

Next. As I never had a Dlink router, this is from the online manual:

Login to router configuration at address 192.168.0.1, go to Network Settings and then DHCP Reservations List, and delete all entries. Or got to Number of Dynamic DHCP Clients and do Revoke to all the entries.
This is so that the router will forget that you're all 192.168.0.100.

Ensure also that under Network Settings / DHCP Server Settings you have Enable DHCP Server, and that DHCP IP Address Range is 192.168.0.2 to 192.168.0.254.

Now turn off all the computers, reboot the router, then boot all the computers.

If the situation isn't re-established correctly, reset the router to factory settings and reconfigure. If this doesn't help, then your home network is probably haunted.

share
    
+1 for haunted home networks! ;) –  Aaaaaaaaaha ERLEBNIS Oct 23 '09 at 8:11
    
I will give this a try. –  ricbax Oct 24 '09 at 22:00
add comment

If the DHCP range is set from 192.168.0.100 to 192.168.0.100, then expand the DHCP range from 192.168.0.100 to 192.168.0.150 on the router and then set your computers to get an IP and DNS dynamically. If that does not work, set the computers to static IPs 192.168.0.5, .6 and .7 and see how that works.

share
add comment

are all of the computers set to have a static IP, or are they set to get their IP from a DHCP server? because it sounds to me like they're all configured to simply use that one IP without asking the router for one that isn't used

share
    
They request via DHCP –  ricbax Oct 23 '09 at 5:11
add comment

If the router is set to dhcp why not try to go a static route? Assign ip's to each of the 3 laptops either via the router by mac or via the laptop in the network configuration. If they are all competing for that one ip that should fix it.

Tho as to why they are all trying to get that one ip instead of getting another I have no idea.

share
    
-1 Assigning static IP addresses to laptops makes it rather more difficult to be portable to other networks. –  Shannon Nelson Nov 14 '09 at 6:04
add comment

This site is currently not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .