Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed Ubuntu using Wubi.

It works fine, but for some reason I see 2 entries of Ubuntu (which run the exact same OS) on the boot-up of the computer.

it seems that on Windows 8, I need to use a tool called "bcdedit" (using admin permissions), so I tried in the console to type

bcdedit

and this is what I got about the duplicate entries:

Real-mode Boot Sector
---------------------
identifier              {9dd88019-846f-11e1-afba-9ec96921aa26}
device                  partition=D:
path                    \ubuntu\winboot\wubildr.mbr
description             Ubuntu

Real-mode Boot Sector
---------------------
identifier              {e0f9b8e5-bfba-11e1-a157-1c6f6525fc11}
device                  partition=D:
path                    \ubuntu\winboot\wubildr.mbr
description             Ubuntu

makes sense, so I decided to delete the second one, using:

bcdedit /deletevalue {e0f9b8e5-bfba-11e1-a157-1c6f6525fc11}

but it didn't work. it showed:

The element data type specified is not recognized, or does not apply to the
specified entry.
Run "bcdedit /?" for command line assistance.
Element not found.

what have I done wrong? I remember that in the past this was much easier, as I could simply edit the boot.ini file. What can I do to fix it?

share|improve this question
    
Try: bcdedit /delete {e0f9b8e5-bfba-11e1-a157-1c6f6525fc11} –  QMechanic73 May 7 '13 at 19:15
    
it worked. such a quick answer. why did you put it as a comment? and what does deletevalue do anyway? –  android developer May 7 '13 at 19:18

1 Answer 1

up vote 1 down vote accepted

Use bcdedit /delete {identifier}.

bcdedit /delete: Deletes an element from a specified entry.

bcdedit /deletevalue: Deletes a specified element from a boot entry.

Use bcdedit /? for display a list of Bcdedit commands.

Read the article from Microsoft.

share|improve this answer
    
what's "numproc" ? the link doesn't say anything about it. also, you should have written here the answer and not just the explanation... –  android developer May 7 '13 at 20:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.