Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Debian 7 on some newly designed hardware. After bootup the Ethernet is not setup correctly, but if I run an "/etc/init.d/network restart" or do an if down/up after bootup then it works. Does anyone know how to make the Ethernet work on the first boot without this 2nd stage configuration step?

The system does seem to take a few seconds to see that the network is alive, as is shown below. Maybe this delay is causing some type of startup problem with Debian?

> [   18.343688] net eth0: CPSW phy found : id is : 0x7c0f1 [  
> 18.358673] ADDRCONF(NETDEV_UP): eth0: link is not ready [   21.342437] PHY: 0:00 - Link is Up - 10/Full [   21.347167]
> ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready [....] Configuring
> network interfaces...[   24.365051] net eth0: CPSW phy found : id is :
> 0x7c0f1
share|improve this question

1 Answer 1

I had this bug too on my am335x-based device only when I enabled both cpu frequency scaling and PREEMPT. I chose to disable PREEMPT as a workarround.

share|improve this answer
    
Welcome to Superuser! This may solve the question, but we need instructions to offer a proper upvote. Can you please edit your answer to add more information, such as what that switch does, where you change it, how you found out that was the solution, etc? We want to help more than just the person having the problem right now –  Canadian Luke Feb 3 at 17:20
    
"We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is correct, ideally with citations. Answers that don't include explanations may be removed." –  deleteme Feb 3 at 17:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.