Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using a USB to Serial converter on /dev/ttyUSB0 and need the group gpib to have access. I'm running Ubuntu 10.02

ls -l /dev/ttyUSB0

outputs

0 crw-rw---- 1 root 188, 0 2013-05-07 13:58 /dev/ttyUSB0

I don't see a group there...I have written a rules file in /etc/udev/rules.d/80-mdrive.rules

KERNEL="ttyUSB*",MODE="0660",GROUP="gpib"     

When I run the command:

screen /dev/ttyUSB0

I get an error such as:

Cannot open line /dev/ttyUSB0 , Device busy or ....(too fast to read)
Sorry could not find a PTY

I'm stuck here... TIA wbg

share|improve this question
    
After restarting, the screen program will connect to my device ONCE...then return the same error. –  wbg May 7 '13 at 21:29
    
interesting fact...I'm actually using PySerial to communicate with a step motor ( device above on /dev/ttyUSB0 ) and PySerial connects with the interface everytime...I don't really need screen but am such a newbie I could still use some help... –  wbg May 8 '13 at 0:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.