Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a weird problem. I try to open the Windows Firewall settings through the control panel. What i do, basically , is to click on Control Panel > System and Maintenance > Windows Firewall. Well nothing happens. No error message no nothing. Just nothing opens. The service runs as it should. Any ideas? Thanks in advance.

share|improve this question

migrated from stackoverflow.com May 8 '13 at 11:59

This question came from our site for professional and enthusiast programmers.

    
given you had no luck with restore.. there may be a regsvr command of sorts to uninstall and install it. But, consider if xp, a repair installation. if windows 7 it may be called an upgrade installation and need to be done from within windows though i haven't tried it. –  barlop May 9 '13 at 14:41
    
an SFC /SCANNOW might be worth a shot –  Bryan May 9 '13 at 14:46

1 Answer 1

try using start > run > firewall.cpl

Try restoring system to a fine restoration point, or copy %windir%\System32\firewall.cpl from a fine windows installation to replace yours. This issue may be caused by data corruption in firewall.cpl.

share|improve this answer
    
Tried that. Nothing happened –  Pantheo May 9 '13 at 7:46
    
@Pantheo Running that command opens the firewall so you probably have some corrupt files - have you tried the second suggestion? –  easwee May 9 '13 at 14:57
    
@easwee I run sfc /scannow. The process did not find anything wrong with my Windows files. Still cant open the firewall. The strange thing is that if i disable the firewall i can open the firewall settings through the control panel. –  Pantheo May 14 '13 at 15:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.