Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

As the title states, I turned off secure boot and installed fedora 18 as usual using a liveUSB installer. This seems to have really miffed windows and now it refuses to boot.

Grub2 comes up fine, I see the Windows 8 loader entry there and fedora is there. I can boot into fedora just fine, but when I try too boot into Windows 8, I'm met with an error:

Boot configuration file is missing. Repair using install media.

The error code I get is 0xc0000225.

I've tried following a lot of guides online, but none of them seems to be dealing with my type of problem.

I tried automatic fixing. It didn't work.

I've tried using bootrec using the command prompt on a usb recovery disk. It didn't help. ( I followed the instructions here )

Running bcdedit gives me

The boot congiguration data store could not be opened. The volume for a file has been externally altered so that the opened file is no longer valid.

The partitions, Windows8 OS partition and the Recovery partition are both there. (I checked using gparted) so the OS hasn't been over-written.

I'd like to know if I can repair the bootloader to show and boot both windows and Fedora?

share|improve this question
Fedora was the first Linux distro AFAIK to include Secure Boot support using shim, so I advise you to re-enable SB, see if Win8 boots, if not repair it so it hopefully does, then get rid of the Fedora partitions and try to reinstall with SB. – Karan May 13 '13 at 23:10
Repairing Windows is the primary part I need help with. – ffledgling May 13 '13 at 23:40
Try the same procedure you used before with bootrec, but after you've re-enabled Secure Boot. I feel disabling that is what is causing Win8 (and Win8 repair) to choke. – Karan May 14 '13 at 12:18
I can't boot through a USB when secure boot is enabled. Infact I can't boot into anything when secure boot is enabled. I can't boot windows, can't boot via pendrive to repair it can can't boot into Fedora. It sort-of goes into a loop and starts asking me which medium I would like to use to boot. None of them works though. – ffledgling May 14 '13 at 20:21
Hmm, well booting from USB should be possible even with SB enabled, by going through the UEFI shell's options, but there are so many different UEFI implementations out there by different motherboard manufacturers that one can't really provide generic advice. Also at this point it's not really clear whether the damage can be undone, so perhaps a complete nuke and redo might be in order. If you have a Win8 DVB/USB you should try to boot in UEFI mode and install it after nuking all partitions, then proceed with Fedora if that succeeds. Or use the recovery option first if that's available. – Karan May 14 '13 at 22:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.