Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The problem that I am running into is that when I cd into my Applications folder and try to ls to see all my folders it doesn't show anything. This is the only directory that does this as I am able to go to any of my other directories and use the usual commands. Another thing that I tried was to jump to a path from my home directory to a folder within the Applications folder and I get No such file or directory. I input the path both with and without quotes and still nothing:

cd ~/Applications/MAMP/bin


cd ~/'Applications/MAMP/bin'

I am using the standard Terminal provided and haven't messed around with any settings. Thanks in advance!

share|improve this question

migrated from May 8 '13 at 18:56

This question came from our site for professional and enthusiast programmers.

maybe your apps are in /Applications and not in ~/Applications? – kch May 8 '13 at 13:01
Tried it a no luck. It is weird because if I ls the root directory the Applications folder shows up so I cd into it and it shows that I am currently in that directory. But from there if I try to ls within it nothing happens – Julian Feliciano May 8 '13 at 13:45
Are you on OSX? What are you expecting to see in /Applications and/or ~/Applications? – ForeverWintr May 8 '13 at 19:00
might help to see a full transcription of your terminal operations here. – kch May 10 '13 at 15:54

I had to type in:

cd /

to bring me to the root directory. Then you type in


and it displays all of the applications.

I think that it puts all of your applications for all the users into the root folder directory so all of the different users can access them. My personal folder/applications was empty.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.