Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to launch OMXplayer and play a sequence of videos on loop on a RaspberryPi running Raspbian Wheezy. I have got a working shell script which launches and plays the videos courtesy of http://www.cenolan.com/2013/03/looping-video-playlist-omxplayer-raspberry-pi/

I have this placed in /home/pi/ and it is executable. I have created a file testsh.desktop in /usr/share/applications/ which I have also made executable. This file contains:

[Desktop Entry]
Version=1.0
Type=Application
Terminal=true
StartupNotify=true
Name=Play
Comment=Plays videos
Exec=/home/pi/playvideos.sh
Categories=Application;

I have also tried setting exec as:

Exec=lxterminal --command "/home/pi/playvideos.sh"

This isn't working and I guess I am missing something obvious.

share|improve this question
    
Weird, it works ok in KDE, but not on my Raspberry PI. –  parkydr May 8 '13 at 21:28

1 Answer 1

up vote 0 down vote accepted

It doesn't work if you have Terminal=true, it runs

x-terminal-emulator "/home/pi/playvideos.sh"

x-terminal-emulator is lxterminal which needs --command to run a command

Either:

Set Terminal=false and run the script with

Exec=lxterminal --command "/home/pi/playvideos.sh"

as you tried before.

Or:

Set Terminal=true and run the script with

Exec=--command "/home/pi/playvideos.sh"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.