Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed Debian Wheezy in VMWare Player 5.0.2 build-1031769 and all is fine. Except the "Failed to load Gome3" messages keep on coming. This is what I did so far:

  • Installed VMWare Tools (some answers on the web claim that did does the trick. No luck so far here).
  • Setting the accelerate 3D Graphics to true in the virtual machine (some answers on the web claim that did does the trick. No luck so far here).
  • Install Whezy into Oracle VirtualBox (some answers on the web indicate that Virtualbox has sometimes better support . Allthough that may true, still no Gnome3, just the fallback).
  • One site suggest I just have to make a ~/.config/autostart/gnome3-desktop file and restart the session (still no Gnome3).

The question is simple: Is there a way to make this working ? Other than waiting on Gnome3 suppport in VMWare Player.

share|improve this question

I had the same issue, and got it to work following the instructions here: http://www.neowin.net/forum/topic/1217775-debian-how-to-fix-gnome-3-failed-to-load-running-debian-in-vmware/

You'll need the following packages:

apt-get install autoconf libtool xutils-dev xorg-dev flex bison  libx11-xcb-dev libxcb-glx0-dev g++ git
apt-get install libxcb-dri2-0-dev libxcb-xfixes0 libxcb-xfixes0-dev llvm libxml2 libxml2-dev python-libxml2 build-essential
apt-get build-dep mesa

then, in some temporary directory:

git clone git://anongit.freedesktop.org/xorg/driver/xf86-video-vmware
git clone git://anongit.freedesktop.org/mesa/mesa
git clone git://anongit.freedesktop.org/git/mesa/drm

Then you'll need to make the projects.

drm:

cd drm
./autogen.sh
./configure --enable-vmwgfx
make
make install

mesa:

cd mesa
git checkout remotes/origin/8.0
git checkout tags/mesa-8.0.5
./autogen.sh
./configure --prefix=/usr --enable-xa --with-gallium-drivers=svga --with-dri-drivers= --disable-egl --disable-glu --disable-glw
make
make install
cd ..

xf86-video-vmware:

cd xf86-video-vmware
git checkout tags/xf86-video-vmware-13.0.2
./autogen.sh
./configure --prefix=/usr
make
make install

Then reboot.

Note: instructions copied here in case the neowin page is unavailable, read the orginal post if you run into issues (it is more detailed). Credit due to "theblazingangel" over there.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .