Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do I type lower case Ñ or umlaut Ï in Windows 8? I have the US-International keyboard layout selected. When I try to type a lower case version of those letters (and possibly more), then it fails. In Notepad, it just prints a plain lowercase 'n'. In Wordpad (Calibri font), it doesn't print anything at all. In this text box (Chrome), it prints a plain lowercase 'n'. I also can't type anything with a circumflex. BTW I'm typing those characters by pressing " + i or ~ + n.

Imgur

Imgur

share|improve this question
    
I haven't researched this but, have you tried writing it in word and copy/paste it into the text box you're having problems with? It might not be the keyboard. It might be the text editors limited support for unicode. –  Ben Plont May 9 '13 at 15:23
    
BTW I'm typing those characters by pressing " + i or ~ + n. –  Chloe May 9 '13 at 15:24
1  
What language packs do you have installed on your system? –  Ramhound May 9 '13 at 15:24

4 Answers 4

up vote 4 down vote accepted

Update

I have been trying some tests to narrow it down for you, on my system - I had to remove the US keyboard fully for the international keystrokes to work. Only then did it start working for me (such as: ô, ñ, ï).

Of course, that makes using some of the overlapping special characters more difficult to use.

Other Option

The other, more laborious option, is Windows Alt Codes. The way this works is you hold ALT and type out the numbers on the numpad (in my experience, it must be the numpad).

For ñ: ALT+0241

For ö: ALT+0246

The Alt codes work without an international keyboard setting, if others need it short term in the future.

share|improve this answer
1  
Yes, ALT+0241 works in Wordpad, Notepad, and Chome: ñ. However, I can't memorize all those numbers. I'm pretty sure the keyboard layout used to work, or at least on XP I know it did. –  Chloe May 9 '13 at 15:26
1  
You could create macros for the characters you use most often. –  Ben Plont May 9 '13 at 15:31
    
@BenPlont I was thinking the same thing, since I am not finding much about fixes for the OP's problem. But the issue then is remembering all the macros! –  nerdwaller May 9 '13 at 15:34
    
@nerdwaller Well, you gave a great answer to the OPs question! –  Ben Plont May 9 '13 at 15:41
1  
@Chloe - I updated this for you, I tried a few methods and I had to delete my US keyboard for the keystrokes to work as you suggested. Only after that, did it work in Chrome/Notepad/etc. –  nerdwaller May 9 '13 at 18:07

If you want to type foreign language such as Spain or German then you should install another IME. Different IMEs can run on a specific keyboard layout. Otherwise you can only type by alt+code or altGr+key in some layout

share|improve this answer

I discovered how to do this for myself through much trial and error. Normally on the U.S. International keyboard you would do Shift + ~ + n, but as you said that gives you the capital Ñ. What you need to to is:

After holding down Shift and ~, let go of Shift before pressing n. So what you do is Shift + ~ + (Let go of Shift) + n.

share|improve this answer
    
I don't hold shift while pressing n. I believe this was an error in Windows 8 and it has been corrected after an update, or else I removed the US keyboard and re-added it as above (don't remember). fïñ. –  Chloe Sep 29 '13 at 22:21

Hold alt and type 164 for ñ

then alt 165 = Ñ

so hold alt first then press 1 then 6 then 4 then release your fingers from the keyboard at the same time.

share|improve this answer
1  
Explain how to determine these numbers. –  Kevin Panko Oct 2 at 3:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.